PDA

View Full Version : 4.3 Coolant Leak, URGENT



s10blazed
03-23-2002, 06:43 PM
Ok, First off I am pissed at the truck. I have owned it 6 days and already I get a chipped windshield and now I am leaking coolant pretty bad. I can't quite see where it's coming from though. Its on the driver's side. From the top it looks like it's down below and down below it looks wet all the way up. The wetEST part is right in front of the motor mount. It was tough to pin point it more precisely without jacking it up. If anyone has an idea of what I should look for or have had anything similar happen please help me out. If there is anything else you would like to know to help out, I can look and let you know. This is really bothering me. I can't drive it until its repaired!!

oh yeah, its a 96 S-10 ext cab, 4.3 Vortec MFI.

THANK YOU IN ADVANCE

TooLowTacoma
03-24-2002, 08:56 AM
yea i feel ya even tho u deleted my previous post...but hope ya get it fixed:bigthumb:

blazin91dan
07-09-2003, 10:02 PM
y is this in the vid section? lol

s10blazed
07-10-2003, 02:52 AM
very old thread. I also believe at one time it was falsely moderated by a problem user and most threads were put here as a joke. (he was told he was a moderator of this forum but had no real moderating powers)

Blazin Low
07-10-2003, 02:58 AM
TooLowTacoma LOL

s10blazed
07-10-2003, 08:21 AM
TooLow wasn't the person that was given fake mod powers, was he? I thought it was a different person. Or maybe it was just one of his many identities... No need for this thread anymore...

Blazin Low
07-10-2003, 01:58 PM
nah it was 87blazer...

drugs r bad...mmmmmmmkay