Results 1 to 6 of 6

Thread: HELP!!!! fuckin seals!!!!

  1. #1
    THE ONE AND ONLY Exoticustoms's Avatar
    Join Date
    Jun 2002
    Location
    RiGhT BeHiNd U!
    Posts
    1,655

    HELP!!!! fuckin seals!!!!

    ok my tranny keeps pushin the seal completely out of the tranny, so i got a keeper put on it and this time i thought it did it again but this time it just blew the seal, what would cause this??? someone told me to change the filter and then put a new seal in and try that but its like the tranny has to much pressure in it????????????? i done changed it twice in last couple of days and i'm about to sell it cause its pissin me off


    PLEASE HELP!!!!!!!!!!!!!!!!!:mad:
    http://groups.msn.com/ExoticCustoms

    this link is for my truck club, feel free to join the site is still being built but most of it is up and running.

    http://www.exoticustoms.8m.com

    muhahahahahaha(evil laugh):D
    check this link out:)

    http://www.albinoblacksheep.com/flash/sierranaked.jpg/

  2. #2
    Box Luv BlazingDood13's Avatar
    Join Date
    Jan 2002
    Location
    Ft.Worth, Tx
    Posts
    2,068
    hmmm do u have to much Trans fluid in it?
    www.DFWminis.com

  3. #3
    My S-10 fleet is gone... s10blazed's Avatar
    Join Date
    Oct 2001
    Location
    Near Pittsburgh, PA
    Posts
    7,537
    Do you mean the tranny pan seal? I thought thats where mine was leaking before too. I even thought the pan was warped and bought brand new one, with 3 gaskets and it still leaked. It ended up being the front seal, which I still have yet to replace. The way it runs out, it seems like its coming from the pan. If you find out any information, I would also like to hear it. :bigthumb:

  4. #4
    Registered User
    Join Date
    Nov 2002
    Location
    Oxford Pa.
    Posts
    70
    Which seal?

  5. #5
    THE ONE AND ONLY Exoticustoms's Avatar
    Join Date
    Jun 2002
    Location
    RiGhT BeHiNd U!
    Posts
    1,655
    the front seal, not pan seal or tail shaft seal, and this time it didnt push it out i guess it just ruined the seal so fuck that tranny and torque converter.... i just bought a 95 model shortbed s10 and it has a ruff body and a tranny that will work with the torque converter still stuck in it so the seal is good and i plan to take my cab and bed off and put that 95 model cab and bed on my frame and while the cabs off i'm gonna switch the trannies and have me a 95 model in a few days all i gave for the 95 was 300 bucks, with a ruff body and good frame, tranny and 95 model steel wheels i'm gonna put my trucks cab on that frame and set it aside for a v8 swap sometime in future and i'll just go prostreet on its ass:)

    someone told me the torque converter could have a burr on the shaft or the vent tube could be plugged up or or the filter could be plugged up, i dunno tired of fuckin wit it:)
    http://groups.msn.com/ExoticCustoms

    this link is for my truck club, feel free to join the site is still being built but most of it is up and running.

    http://www.exoticustoms.8m.com

    muhahahahahaha(evil laugh):D
    check this link out:)

    http://www.albinoblacksheep.com/flash/sierranaked.jpg/

  6. #6
    Registered User blazinindayton's Avatar
    Join Date
    Jan 2003
    Location
    kettering, OH
    Posts
    110
    when you put the new filter in did you pull out the old piece that was in it to seal the filter tube? you could have two of them in there and have a problem with the filter not being in far enough.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •