Results 1 to 13 of 13

Thread: high rev after it turns over 97 4.3v6

  1. #1
    Beer,Its whats for dinner Paraquat's Avatar
    Join Date
    Feb 2002
    Location
    Connecticut
    Posts
    2,057

    high rev after it turns over 97 4.3v6 (new problem for 6/21)

    My truck usually idles around 600 (700 ish with the ac on) but ever since I had a shop do my motor mounts when I first turn it on it revs at about 1200
    This took me by surprise the first time as it felt like my truck was leaving without me, since its new idle speed was about 25 mph.
    If I leave it in park, and tap the throttle to about 2k, it 'll come back down to 600 area
    Why?


    --Steve
    Last edited by Paraquat; 06-23-2003 at 09:52 AM.
    I hate my truck.

  2. #2
    Senior Member bigjsp's Avatar
    Join Date
    Nov 2002
    Location
    Columbus, OH
    Posts
    12,665
    Normally the Idle is set by the Idle Air Control motor.

    Wacking the gas shouldn't make any difference, but I believe you that its happening.

    Check the throttle cable and bracket didn't get kinked or bent during the motor mount-ectomy.

    Really bizarre stuff but try checking for vacuum leaks while its revving. We had a car which would idle real fast in the morning then oncece you drove it and shut it off. You could start it back up and it would be fine the rest of the day. Turned out to be a vacuum leak which I believe was sealing once the motor stopped sucking on it but yet the temperature was warm enough to let it close the hole.

  3. #3
    . CBZED101's Avatar
    Join Date
    Aug 2002
    Location
    San Antonio, TX
    Posts
    4,211
    Yeah, my cousins truck idled at 30MPH, found a leak in a vacuum line, patched it, and now it runs normal

  4. #4
    Beer,Its whats for dinner Paraquat's Avatar
    Join Date
    Feb 2002
    Location
    Connecticut
    Posts
    2,057
    It's not vacuum. It holds pretty good.
    Someoen suggested cold start injectors may be functional now
    and then my dad suggested the cable is gettin caught on soemthing?
    Also, my fan is broken. So ill be posting and bitchin about that too.
    The cables didnt seem to be getting caught, but there was some play in the right one.

    http://www.mastrianni.net/stevespict...ges/cables.jpg
    http://www.mastrianni.net/stevespict...s/playleft.jpg
    http://www.mastrianni.net/stevespict.../playright.jpg

    I think it may have better acceleration now though? I've only had it back for 3 days, I havn't had tiem to plot the fuel consumption. Maybe I should invest in a fuel air ratio meter?


    --Steve
    I hate my truck.

  5. #5
    Beer,Its whats for dinner Paraquat's Avatar
    Join Date
    Feb 2002
    Location
    Connecticut
    Posts
    2,057
    It uh, stopped.
    On its own.
    And I get 17 mpg now.
    As opposed to 14
    but I also took my box out.


    --Steve
    I hate my truck.

  6. #6
    Beer,Its whats for dinner Paraquat's Avatar
    Join Date
    Feb 2002
    Location
    Connecticut
    Posts
    2,057
    Ok, so after that stopped. Now my brake, when depressed, maeks a breathing sound.
    I push it to the floor and the car's idle jumps to 650 and down to 300-400. It gets so low that it stalled 4 times today.
    If I jump on it, it will stop without the noise
    If I go slow on it is when it makes the noise and eventually sinks to the floor, but then it fights back! It pushes back and eventually gets stronger than I am.
    This is a little scary when stopped at a light with cars doing like 50 perpendicular infront of you
    My uncle suggested master cylinder? Just want to make sure before I go and bleed everything and deal with taht nonsense.


    --Steve
    I hate my truck.

  7. #7
    Registered User hotrodblazer4.3's Avatar
    Join Date
    Nov 2002
    Location
    Hanover,PA
    Posts
    372
    Probably the Brake Booster. Works off vacuum, and from what you are describing it sounds like the diaphragm is bad. This is an expensive part, so you should probably take it in to have it properly diagnosed instead of changing out parts and hoping you get the right one.
    The above opinion is my own and is subject to ridicule since age and experience mean nothing on these forums.

  8. #8
    Senior Member bigjsp's Avatar
    Join Date
    Nov 2002
    Location
    Columbus, OH
    Posts
    12,665
    bad brake booster

    but check the volume and strength of the vacuum at the booster before you bust your knuckles.

  9. #9
    Registered User Catching Second's Avatar
    Join Date
    May 2003
    Location
    Charles Town, West Virginia
    Posts
    4,308
    I don't know the specfics on what it is but all of the Chevy trucks in my driveway start out at a high-ish idle and then when you tap the gas it kicks the idle down.
    "A true hotrodder wouldn't be content untill he had created a car so violent, so hairy, so totally sick that the very act of dropping the hammer would result in instant death. Anything less results in the need to go faster." - Tony DeFeo

  10. #10
    Beer,Its whats for dinner Paraquat's Avatar
    Join Date
    Feb 2002
    Location
    Connecticut
    Posts
    2,057
    I stall sitting at stop lights.
    Also, today, the brake pedal became hard as a rock, and pushing it did nothing
    if I really got on top of it it'd slow down, but then try to stall once I was stopped.
    Then applying throttle it would bog for a second and then pick up as if in second gear already


    --Steve
    I hate my truck.

  11. #11
    Registered User hotrodblazer4.3's Avatar
    Join Date
    Nov 2002
    Location
    Hanover,PA
    Posts
    372
    You really need to get this fixed before you end up wrecking it and hurting yourself or some one else. Rear ending some one is going cost a lot more then getting it fixed.
    The above opinion is my own and is subject to ridicule since age and experience mean nothing on these forums.

  12. #12
    Beer,Its whats for dinner Paraquat's Avatar
    Join Date
    Feb 2002
    Location
    Connecticut
    Posts
    2,057
    I know, but I needed to drive for work today to do deliveries and shit
    earliest I can even have it looked at is saturday.
    Im going to be riding the bike the rest of the week.


    --Steve
    I hate my truck.

  13. #13
    Stalker Nate Audiodogg's Avatar
    Join Date
    Apr 2002
    Location
    Langley, BC, Canada
    Posts
    2,610
    Isn't the stock idle 750 or so on a 4.3?? If you drop down lower you'll always shut off. I've seen quite a few blazers that started up and idled high..say 1500 or so for the first 2mins and then it slowly dropped. Or when the tranny is shifted out of P then it might drop again..

    It could just be something with the engine or it could be an unsolved problem...like the ones I've seen which had been checked out numerous times.

    Nate

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •