Results 1 to 10 of 10

Thread: Gear indicator light wont change?

  1. #1
    Registered User
    Join Date
    Mar 2002
    Location
    Minnesota
    Posts
    53

    Unhappy Gear indicator light wont change?

    Hey,

    I bought a 1988 S-10 4x4 Blazer about 2 weeks ago,
    but im wondering why on the shifter on the floor,
    "to switch it between 2 wheel, 4 high, nutreul, and 4 low"
    anyway the indicator light does not switch when it is shifted between the gears, it always stays on 2 wheel.
    It does switch the gears just not the light, does anyone know why the dang light wont switch or how I can fix it so it will switch.

  2. #2
    My S-10 fleet is gone... s10blazed's Avatar
    Join Date
    Oct 2001
    Location
    Near Pittsburgh, PA
    Posts
    7,537
    Do you drive it for a minute or two first? My light never changes instantly... it'll just switch after driving about 2 blocks in that gear. Try that if you haven't already. Other than that, it is probably a vaccuum line somewhere. I know on my 88, I have changed just about every one so far.... :(

  3. #3
    Senior Member u_aint_REDie's Avatar
    Join Date
    Nov 2001
    Location
    South NJ
    Posts
    2,356
    are you putting it in Reverse while shifting through the gears, the only way the hubs lock is when shifted in reverse. that should be the indicatator light on with in seconds of shifting back into drive NOT OVER DRIVE
    1985 Chevy s-10 Blazer 4x4
    2000 Chevy s-10 LS Standard Cab

  4. #4
    Registered User
    Join Date
    Mar 2002
    Location
    Minnesota
    Posts
    53
    Yeah I shift it in reverse first to get through the gears, and I drove how ever far I had to, like just last week we had a bad snow storm and the plows didnt get out there and get all the roads done so I put it into 4 high and I drove in 4 high for atleast an hour total if not more the whole time the indicator light stayed on 2 wheel but it was actually in 4 high.
    So if anyone knows what the problem is and aproximetly what it could cost to fix it , it would be very helpfull

  5. #5
    Senior Member u_aint_REDie's Avatar
    Join Date
    Nov 2001
    Location
    South NJ
    Posts
    2,356
    does the little indicator that lights up the front wheels on the diagram light up when placed in 4 wheel drive?
    1985 Chevy s-10 Blazer 4x4
    2000 Chevy s-10 LS Standard Cab

  6. #6
    Registered User
    Join Date
    Mar 2002
    Location
    Minnesota
    Posts
    53
    No the indicator light does not change when I switch into 4 high, nutreul, and 4 low.
    It will always be lit up on the 2 wheel drive.
    Now it is switching into the other gears its just the light does not follow it will always stay on 2 wheel.
    I sappose it isnt a big deal since it is switching through the gears , im just wondering if this has happened to any of you guys and how I would go about fixing it

  7. #7
    My S-10 fleet is gone... s10blazed's Avatar
    Join Date
    Oct 2001
    Location
    Near Pittsburgh, PA
    Posts
    7,537
    When I have mine in 4 wheel drive, the red light beside 2 wheel drive (the words) doesnt change... it stays there. But the 2 front wheels in the picture of the truck light up. That is good enough acknowledgement for me that it engaged properly.

  8. #8
    Registered User
    Join Date
    Mar 2002
    Location
    Minnesota
    Posts
    53
    Nothing lights up but the 2 wheel LED there is the words of the gears and then there are the 3 LED's that are sapposed to change when I change the gears there is also a diagram but nothing lights up on that either, the indicator light (LED) will just stay on the 2 wheel (word) no matter if I switch it into 4 high, Nutrel, or low

    Any suggestions ? :confused: :confused:
    Last edited by sector; 03-26-2002 at 11:41 PM.

  9. #9
    TL8 BEDAN77's Avatar
    Join Date
    Feb 2002
    Location
    Miss, Ont.
    Posts
    1,140
    my light takes time to change....
    but when i put it in 4high it sometime sslips into 2wd, and when i put it into neutral or 4low it allof a sudden makes this electronic grinding noise and shit and it scares the shit outta me cause i think im fucking somthing up ...
    what is this noise and whats wrong?>
    MY BLAZER IS FOR SALE - CHECK THE CLASSIFIEDS

    $3000 O.B.O

  10. #10
    Registered User
    Join Date
    Mar 2002
    Location
    Minnesota
    Posts
    53
    Yeah the same Shi* happens to me it grinds between gears like that although I thinks thats just normal, i might me wrong but I thinks its normal but my light doesnt ever change it always stays in 2 wheel

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •