Results 1 to 4 of 4

Thread: TA radials SUCK!

  1. #1
    Senior Member bigjsp's Avatar
    Join Date
    Nov 2002
    Location
    Columbus, OH
    Posts
    12,665

    TA radials SUCK!

    I blown one out the side , shread the tread and messed up my bumper and paint, now I've got one with a broken belt. That 3 out of 4 so three strikes and they are outta here.

    Air pressure was in the 35 to 45 tire was running cool so I can't explain other than they are crap for my application.

    Michelins blow up too.

    Thinking about the Goodyear nascars?

    Anybody running a P235 60 R15 tire that holds up under towing ?

  2. #2
    Registered User ZZ4Blazer's Avatar
    Join Date
    Dec 2001
    Location
    Akron, Ohio
    Posts
    6,226
    Never had a problem with any of mine. But, I never towed either. Thats not that big of a tire. Your not overloading it are you?
    Jim 94 Stepside
    ZZ430 clone V8
    NX kit in the works
    Tremec T56 6 speed
    8.5" rear
    Quote Originally Posted by Harley
    Go before show any day of the week.

  3. #3
    Senior Member bigjsp's Avatar
    Join Date
    Nov 2002
    Location
    Columbus, OH
    Posts
    12,665
    The P235 60 R15 are the front tires (8" tread).
    I've got 295/50SR15 T/As on the back (around 12"). With the bolt on wide side rear flares it gives the limo truck a nice look.

  4. #4
    Registered User ZZ4Blazer's Avatar
    Join Date
    Dec 2001
    Location
    Akron, Ohio
    Posts
    6,226
    I've got those on my cragars up front, 275/50's out back. Never had problems with mine. Even threw them on the back for burnoff tires once. Held up pretty good. Don't hook for shit, but still.
    Jim 94 Stepside
    ZZ430 clone V8
    NX kit in the works
    Tremec T56 6 speed
    8.5" rear
    Quote Originally Posted by Harley
    Go before show any day of the week.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •