Page 2 of 3 FirstFirst 123 LastLast
Results 16 to 30 of 39

Thread: EGR valve?

  1. #16
    Insane Network Engineer rlith's Avatar
    Join Date
    Dec 2002
    Location
    Pittsburgh, PA
    Posts
    2,588
    Hmm, it's a 95? You have CPI or TBI? If CPI, and getting gas smell, you more than likely have a bad CPI unit or Nut Kit.... If CPI, pull your upper plenum and look for signs of washing....(Where one side looks cleaner than the other) If the passenger side is washed, you have a bad CPI, if the drivers side is washed, you have a bad nut kit.... Though if you replace the CPI, you should replace the nut kit as a matter of course, because at that age, they become very brittle...
    Support Sattelite Radio! Goto www.siriusbackstage.com
    goto http://www.pghconsulting.net/teal to see my updated pics!
    ____________________________
    95 S10 Blazer 4x4, Vortech CPI, EGR mod, 99 Centerconsole w/ shifter, , 2001 Extreme zq8 steering box, Pioneer head unit, Leather interior

    -- I won't bag it and/or drop it, because face it, I'm too old to have a ghetto-mobile
    "I live with 2 retards and a deaf person.....It's not so bad..." --Grandma

  2. #17
    Banned jonathan's Avatar
    Join Date
    Jun 2002
    Location
    meridian,ms
    Posts
    1,206
    where is the egr valve on a tbi at

  3. #18
    Altered Egoz C.C. Brettboom's Avatar
    Join Date
    Jul 2003
    Location
    Grand Blanc, MI
    Posts
    262
    O.K. Here's what you do. Now,the EGR has a piston in the middle when you look at the side that goes toward the motor. Make sure that the piston moves freely. If not try to clean it with carb or T.B. cleaner. If that works, your good. If not you need a new one. After that is settled here's what you do about the screen. I had the same problem on my Bravada when I first bought it. Clean the intake out where the ERG mount using TBI cleaner. To do this you have to hold the butterfly open on the throttle body and spray in there. It will run run to the ERG mount. Also spray in the ERG area. Soak the hell out of it. Blow it out with an air gun and let it dry. Now find some window screen from a hardware store. Make sure that it is a metal not fiberglass. Put that in between the ERG gasket and the block. This will stop any carbon causing the ERG from not working right. Carbon build up is what cause the problem. Put it back together. I had to do this three time before it cleared up. Run the hel out of it when you get it back together. This will help getting all the carbon lose.
    Good Luck,
    Brettboom
    Altered Egoz C.C.
    Boomvda

  4. #19
    Banned jonathan's Avatar
    Join Date
    Jun 2002
    Location
    meridian,ms
    Posts
    1,206
    will somebodyanswer my question

  5. #20
    Blazin no More Blazed's Avatar
    Join Date
    Dec 2001
    Location
    FSU...Tallahassee FL
    Posts
    2,464
    OK...so months after I started getting the symptoms my SES light came on today and I had a really bad idle. I really only have time friday and saturday to work on it. I'm gonna take out the valve and clean it on friday after work and go in saturday morning to make a restrictor. What's the best material to use? Steel? How thick...I was thinking like 1/4 inch. Should I drill holes as a resritor or just have it completly solid? I have no worries about passing emmisions caus ethey dont do it in Vermont.

    Anyone have the demensions or a actual size picture of it to make my life easier? Thanks

  6. #21
    Insane Network Engineer rlith's Avatar
    Join Date
    Dec 2002
    Location
    Pittsburgh, PA
    Posts
    2,588
    drill holes. don't block it off completely, start with 5/32, reset your ECM... If the light comes back on, go 1 size higher (repeat process until light not set anymore), use 1/4 aluminum (won't rust) and 2 gaskets...(one for each side)... Clean your egr with carb cleaner and a wire brush before putting back on...clean the egr port on the manifold as well.. For pics go to http://www.s10planet.com/tech_older_egr.htm , they show the vac based one, but the principal is still the same, it applies to 95 and below (96 and up uses the fitting)
    Support Sattelite Radio! Goto www.siriusbackstage.com
    goto http://www.pghconsulting.net/teal to see my updated pics!
    ____________________________
    95 S10 Blazer 4x4, Vortech CPI, EGR mod, 99 Centerconsole w/ shifter, , 2001 Extreme zq8 steering box, Pioneer head unit, Leather interior

    -- I won't bag it and/or drop it, because face it, I'm too old to have a ghetto-mobile
    "I live with 2 retards and a deaf person.....It's not so bad..." --Grandma

  7. #22
    Blazin no More Blazed's Avatar
    Join Date
    Dec 2001
    Location
    FSU...Tallahassee FL
    Posts
    2,464
    This sucks. I spent all day trying to redo this crap. I got up early and made the restrictor. I got the gaskets from a chevy dealer and they only had one so I got that and one that was similar but bigger. I made the restrictor off the bigger one. It took for ever to take off the left bolt on the ERG valve. I've been up since 8 doing this shit and I jsut finished (3:00) I started up my engine and it sounds all messed up. It kinda of sounds like an outboard engine or big block. It made more of a difference in sound than my damn exhaust did. Is this good or bad?

    I made the restrictor out of 1/4" aluminum
    Drilled 3/16" holes, not excatly centered
    Used fuel injector/air intake cleaner on the EGR valve after scraping off the black ring around the 2 holes.
    Sprayed that out with an air hose.
    spayed inside where the egr vavle attaches tot eh engine

    THe holes didnt line upso after like 2 hours of fuckin with it, modified my gaskets and restrictor

    Sprayed that butterfly before I put the intake hose back on

    Started it up and heard that sound. Drove around for several minutes and the sound didnt go away...Dob;t think I even notice a difference in response and crap.


    Is this new sound good or bad?

  8. #23
    Insane Network Engineer rlith's Avatar
    Join Date
    Dec 2002
    Location
    Pittsburgh, PA
    Posts
    2,588
    Remember, it's only going to help low end torque...Second, when you scraped the port on the intake side, did any carbon fall back into there? If so, it's possible carbon chunks may be blocking the restrictor...Pull the egr and the restrictor and run the engine for a few minutes (light revs) and has it set your SES light... And what sound are you hearing?
    Support Sattelite Radio! Goto www.siriusbackstage.com
    goto http://www.pghconsulting.net/teal to see my updated pics!
    ____________________________
    95 S10 Blazer 4x4, Vortech CPI, EGR mod, 99 Centerconsole w/ shifter, , 2001 Extreme zq8 steering box, Pioneer head unit, Leather interior

    -- I won't bag it and/or drop it, because face it, I'm too old to have a ghetto-mobile
    "I live with 2 retards and a deaf person.....It's not so bad..." --Grandma

  9. #24
    Blazin no More Blazed's Avatar
    Join Date
    Dec 2001
    Location
    FSU...Tallahassee FL
    Posts
    2,464
    What the crap???? I took off the restrictor plate and its still making the sound. It sounds like the burping and chugging sound a big black makes when in idle.

    When I looked in the valve there werent any chunks in there. There was a light ring around where the gasket holes are and I cleaned that off with a wire brush.

    I sprayed inside of the egr valve several times with the cleaner.

    I just sprayed where the egr valve attaches to the block. I didnt really look in it or scrape anything. When I pulled the restrictor there was a light carbon film where the holes on the gasket are.

    Could it be making that chug-a-lug sound cause I didnt tighten the bolts completly back. I got the right bolt alllllllll the way in but I had a little trouble with the left side. I got it as tight as I could until the bolt was on the start to get stripped so I stopped. Its like 96 or 97% in. Theres no gap between the block and gasket or gasket and egr valve

  10. #25
    Insane Network Engineer rlith's Avatar
    Join Date
    Dec 2002
    Location
    Pittsburgh, PA
    Posts
    2,588
    you need to back out that bolt and reseat it... It needs to be torqued to 8 inch pounds .....Even though you can't visibly see a gap, the pressure could be escaping, and/or when you were doing the mod you knocked a vaccum hose off along the way
    Support Sattelite Radio! Goto www.siriusbackstage.com
    goto http://www.pghconsulting.net/teal to see my updated pics!
    ____________________________
    95 S10 Blazer 4x4, Vortech CPI, EGR mod, 99 Centerconsole w/ shifter, , 2001 Extreme zq8 steering box, Pioneer head unit, Leather interior

    -- I won't bag it and/or drop it, because face it, I'm too old to have a ghetto-mobile
    "I live with 2 retards and a deaf person.....It's not so bad..." --Grandma

  11. #26
    Blazin no More Blazed's Avatar
    Join Date
    Dec 2001
    Location
    FSU...Tallahassee FL
    Posts
    2,464
    Any way of getting to it easier?? I'm just using a wrench and turning it a million times. I can't get it tighter without stripping it...I'll try again tomorrow I guess. <aybe that was the problem with the restrictor

  12. #27
    Insane Network Engineer rlith's Avatar
    Join Date
    Dec 2002
    Location
    Pittsburgh, PA
    Posts
    2,588
    use a swivel
    Support Sattelite Radio! Goto www.siriusbackstage.com
    goto http://www.pghconsulting.net/teal to see my updated pics!
    ____________________________
    95 S10 Blazer 4x4, Vortech CPI, EGR mod, 99 Centerconsole w/ shifter, , 2001 Extreme zq8 steering box, Pioneer head unit, Leather interior

    -- I won't bag it and/or drop it, because face it, I'm too old to have a ghetto-mobile
    "I live with 2 retards and a deaf person.....It's not so bad..." --Grandma

  13. #28
    CAN YOU HEAR ME NOW? Audiobahn18s's Avatar
    Join Date
    Jan 2003
    Location
    Salisbury,MD
    Posts
    374
    I use a 3/8" drive 10mm socket with an extension and like RLITH said, a swivel. Should work fine.
    95 2wd 4door Blazer: Bagged
    97 4x4 4dr Blazer: BONE STOCK.....except the alternator

    YOUR HONDA HAS 1.6L, MY MOUNTAIN DEW HAS 2....!!!!!!!!

  14. #29
    Blazin no More Blazed's Avatar
    Join Date
    Dec 2001
    Location
    FSU...Tallahassee FL
    Posts
    2,464
    Ight. I got the swivel things and got it fixed in 20 minutes. Only problem now is that the SES light is still on. I dont have a restrictor on. I bought a new gasket. Its plenty tight and doesn't make that sound anymore. I detached the negative from the battery for 20 minutes. The SES light wasn't on for a ride around the block. I drove it again and came on. This happened 3 times already (disconnecting for 20 min, does the same thing)

    I went to AutoZone but it was too dark for them to check the codes. I have a feeling its gonna pull codes for the EGR valve.

    My idle is weird. It didn't sound weird but the car was shaking during idle. It had a solid idle and didnt bog around though. My blazer never used to shake like that.

    The sound that I was complaining about, like the burbing and stuff, I was hearing that slightly in the exhaust before I did any of this. It doesn't really do that anymore though (exhaust wise)

    What the crap is going on. What years of ERG's can I use? (Like 94+, 94-96, 96+ etc.)

  15. #30
    Insane Network Engineer rlith's Avatar
    Join Date
    Dec 2002
    Location
    Pittsburgh, PA
    Posts
    2,588
    before you put the EGR back on did you clean the EGR and EGR port (scub it with carb cleaner and wire brush) As well as make sure the pintle was clear? Did you clean the EGR port on the manifold? And not to sound stupid, but did you plug the wire harness back into the EGR when you put it back in?
    Support Sattelite Radio! Goto www.siriusbackstage.com
    goto http://www.pghconsulting.net/teal to see my updated pics!
    ____________________________
    95 S10 Blazer 4x4, Vortech CPI, EGR mod, 99 Centerconsole w/ shifter, , 2001 Extreme zq8 steering box, Pioneer head unit, Leather interior

    -- I won't bag it and/or drop it, because face it, I'm too old to have a ghetto-mobile
    "I live with 2 retards and a deaf person.....It's not so bad..." --Grandma

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •