Page 1 of 2 12 LastLast
Results 1 to 15 of 30

Thread: cant find where the noise is coming from.... grrrr

  1. #1
    Positively Negative
    Join Date
    Jan 2004
    Location
    York, SC
    Posts
    1,012

    Thumbs down cant find where the noise is coming from.... grrrr

    i've been getting this knock sound from somewhere under my truck ... sounds about like a bad ball joint and usually seems to come from the front end, but sometimes sounds like it coming from the middle ... and i cant find it



    here is a list of what it definitely isnt
    ball joints
    control arm bushing
    tie rod
    idler arm
    pitman arm
    sway bar bushing
    tbar mounts
    bearing
    shock




    any one have any ideas of what it could be?

  2. #2
    Registered User
    Join Date
    Mar 2004
    Location
    Lubbock, Texas
    Posts
    13
    i'm hearing a popping noise in my front end right now too, it sounds like it's coming from something in the front driverside wheel well. It's in the shop right now trying to figure out what it is, i've taken it in 5 times now for this problem and they have yet to fix it. I'm supposed to get it back tomorrow, i'll let ya know if they figure it out and maybe it'll help you.

  3. #3
    Positively Negative
    Join Date
    Jan 2004
    Location
    York, SC
    Posts
    1,012
    also ... i forgot to mention that you can feel it ... you can feel it in the floor, the pedals, the steering wheel, everywhere :(

  4. #4
    Registered User
    Join Date
    Mar 2004
    Location
    Lubbock, Texas
    Posts
    13
    same here. scares anyone who rides with me and hasn't heard it before to death, they think my wheel is about to fall off.

  5. #5
    Registered User blazinangel21's Avatar
    Join Date
    Nov 2003
    Location
    West Texas
    Posts
    352
    mine does it too.. its a susp. problem i think... my pass. tire also sits further back and rubs slightly when i turn sharp
    Sup

  6. #6
    Puttin the "Sport" in SUV hivoltagedriver's Avatar
    Join Date
    Nov 2002
    Location
    Kansas
    Posts
    2,484
    Mine does that too, but I know for a fact that it is my upper control arm bushings on the passanger side. You can feel it in the floor when it does it. I have polyurethane busning on order from Summit that should fix that shit though.

  7. #7
    Registered User Azer's Avatar
    Join Date
    Mar 2003
    Location
    Alabama
    Posts
    836
    i had bad top control arm bushings on the passanger side and i replaced them and it is still poping. i just learned to live with it
    1990 2Door blazer, dropped 2"up front 3"out back, pioneer DEH-P3600, two 15" kicker comp's, a gm-2000 200watt pioneer amp. SOON TO COME flowmasters, a lower drop, fresh paint, better subs and amps and some 17or18" rims
    :blazer:

  8. #8
    My S-10 fleet is gone... s10blazed's Avatar
    Join Date
    Oct 2001
    Location
    Near Pittsburgh, PA
    Posts
    7,532
    My 4x4 Blazer does something pretty similar but not to the point where it scares people. It's my upper control arm bushings for sure. I had it on a lift where I used to work and in 4wd the whole front wheel assembly would jerk pretty hard when you hit the brakes or accelerated. I never got around to replacing them because like I said, they aren't to the point that its shaking like mad.

  9. #9
    Registered User lowblazin93's Avatar
    Join Date
    May 2003
    Location
    Maryland
    Posts
    87
    check your exhaust to make sure it has not come loose. My exhaust "y" pipe was not connected properly to my cat and it was banging into the frame when i hit certain bumps. I though it was all sorts of shit, but it ended up being that. and checking a loose exhaust is easy to do, just make sure the car is not hot. It's probably not your problem though, but it be nice for it to be something so easy.

  10. #10
    Registered User Catching Second's Avatar
    Join Date
    May 2003
    Location
    Charles Town, West Virginia
    Posts
    4,308
    Make 100% sure that the round rubber thing that goes ontop of your coil spring is on there. If not, the coil spring can make some wild popping noises. Usually when I am putting a coil back in I loosely tape the rubber to the coil, otherwise it's a bitch trying to get it on perfect.
    "A true hotrodder wouldn't be content untill he had created a car so violent, so hairy, so totally sick that the very act of dropping the hammer would result in instant death. Anything less results in the need to go faster." - Tony DeFeo

  11. #11
    Positively Negative
    Join Date
    Jan 2004
    Location
    York, SC
    Posts
    1,012
    no coil spring ... its a 4x4




    exhaust is fine

  12. #12
    Registered User Catching Second's Avatar
    Join Date
    May 2003
    Location
    Charles Town, West Virginia
    Posts
    4,308
    Originally posted by J Phillies
    no coil spring ... its a 4x4

    That's correct.

    Someone didn't read everything thoroughly enough.
    "A true hotrodder wouldn't be content untill he had created a car so violent, so hairy, so totally sick that the very act of dropping the hammer would result in instant death. Anything less results in the need to go faster." - Tony DeFeo

  13. #13
    Positively Negative
    Join Date
    Jan 2004
    Location
    York, SC
    Posts
    1,012
    woohoo! ... i finally found it ... lol


    i was missing a bolt at the top of the transmission mount

  14. #14
    Registered User
    Join Date
    Mar 2004
    Location
    Lubbock, Texas
    Posts
    13
    well, i got mine back...they never heard the pop...guess i'll check my transmission mount and see if maybe that's it.

  15. #15
    Registered User
    Join Date
    Mar 2004
    Location
    missouri
    Posts
    66
    we have a 99 tahoe and it dose it more and more everytime we drive it... but we cant find it we took it down to my dad's car lot and pulled and pushed on everything and nuthing looks unusual we are waiting for it to break when we are driving just so we can find out what in the hell it is in the mean time we run the crap out of it!:D
    i would like to go lower but im poor and cant afford bags yet.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •