Results 1 to 5 of 5

Thread: 5/5 drop, NO BRAKES!!

  1. #1
    Registered User 01blzr2nv's Avatar
    Join Date
    Dec 2003
    Location
    attica, ny
    Posts
    21

    5/5 drop, NO BRAKES!!

    i did a 5/5 drop on my 01 blazer, drove it a week, and now i lost my brakes completly. i remember reading a sticky about this, something about moving the rear brake hoses. anyone have any pics or info on what i have to do. i almost killed myself today trying to stop.help! :confused: :blazer:

  2. #2
    Registered User Nates01Blazer's Avatar
    Join Date
    Nov 2003
    Location
    Indiana
    Posts
    257
    yea from what ive heard, the rear lines have to be flipped downwards or they'll rub through, also did you trim the upper control arms for the proper clearances too?
    2001 Blazer - 2dr 2wd, V6 auto, HPPIII, 5/5 drop with 18's and 20's *SOLD* 98 S-10 StreetSource Profile
    NEW StreetSource Profile
    Click Me - My Gallery!

  3. #3
    Registered User 01blzr2nv's Avatar
    Join Date
    Dec 2003
    Location
    attica, ny
    Posts
    21
    yep, trimmed the a-arms, but never flipped the brake lines, guess i better do that

  4. #4
    Registered User Nates01Blazer's Avatar
    Join Date
    Nov 2003
    Location
    Indiana
    Posts
    257
    what did you use to trim them? pics? im about ready to install mine
    2001 Blazer - 2dr 2wd, V6 auto, HPPIII, 5/5 drop with 18's and 20's *SOLD* 98 S-10 StreetSource Profile
    NEW StreetSource Profile
    Click Me - My Gallery!

  5. #5
    Registered User 01blzr2nv's Avatar
    Join Date
    Dec 2003
    Location
    attica, ny
    Posts
    21
    i dont have any pics, but what i did was grind it down with a cutoff wheel, it seemed to work pretty good

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •