Results 1 to 6 of 6

Thread: Pressure Switch ?

  1. #1
    Registered User Tyus4's Avatar
    Join Date
    Dec 2001
    Location
    mass
    Posts
    769

    Pressure Switch ?

    I've been running the same pressure switch for about 2 years now with no problem until last week....My tank filled and couple minutes later the compressors kicked on for about 2 seconds and shut off..I drove home and next day started my truck and compressors didn't come on like they normally do..and my inline fuse was blown...changed that and today after driving around the compressors kept on kicking on/off on/off...sometimes for 1 second..sometimes for like 5 seconds no longer than like 5 seconds though.... but did it for like 10 times...does this mean my pressure switch is starting to go???
    No More 4 DOOR LOVE

  2. #2
    Box Luv BlazingDood13's Avatar
    Join Date
    Jan 2002
    Location
    Ft.Worth, Tx
    Posts
    2,068
    first thing go over all your wiring make sure everything is still tighter...next listen for any leaks near or around the pressure switch...fill your bags up then let some air out and see if u can hear your pressure switch turn on when it should ...what kind of switch do u have?
    www.DFWminis.com

  3. #3
    Registered User Tyus4's Avatar
    Join Date
    Dec 2001
    Location
    mass
    Posts
    769
    like if i play with my switches the compressors will come on when they are suppose to and shut off when they are suppose to..but when the tank is full they will start kickin on/off....its weird
    No More 4 DOOR LOVE

  4. #4
    Big Swole
    Join Date
    Feb 2003
    Location
    cincinnati
    Posts
    700
    sounds to me like teh switch is going out. just replace it and see if that fixes it. they arent that expensive anyway
    Http://www.streetsourcemag.com/Profile.aspx?ProfileID=26463

    We have become part of something much more complicated than you or I will ever fully comprehend. We build more than just trucks. . . we build friendships, we build futures, we build our dreams. We drive our trucks low and hold our heads high because we have an unwritten and unspoken agreement that we will live life to the fullest and never fall victim to 'the norm'. Others laugh at us when we spend hours on end working on our trucks, yet shake our hands when we are done. --Wyatt Strange


  5. #5
    Doesnt look like this supernova's Avatar
    Join Date
    May 2002
    Location
    baton rouge, la
    Posts
    6,558
    i would say check your wiring first. b/c well, its free to do that. check the connections on everything too. BUt there is a good chance the switch is going bad. They arent too hightech things anyways.

  6. #6
    streetissuecustoms.com low_blazer's Avatar
    Join Date
    Dec 2001
    Location
    Poulsbo, Washington
    Posts
    1,968
    yup....that's the presssure switch dying. I've gone through a few, and they all did that on their last days. It's just a little spring loaded switch...sometimes the spring softens up, somtimes you get a bit of corrosion on there...lots of things can happen to those little things. sometimes they last for 10 years, I've seen them crap out in 2 weeks...
    Doug
    '85 Blazer...bagged, small-blocked, back-halfed and body dropped
    http://streetissuecustoms.com/salesban_3.jpg
    Street Issue Customs

    For all your custom fiberglass, interior or stereo needs... Epicenter Designs

    Originally posted by S/T Lover
    That post would have made more sense if you would have just pissed all over the screen and posted a screen shot of that.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •