Results 1 to 12 of 12

Thread: 02 Going Dead

  1. #1
    Camel Toe Inspector junky2's Avatar
    Join Date
    Jan 2004
    Location
    Georgia
    Posts
    220

    02 Going Dead

    I've got a 02 LS crewcab and it has started going dead
    sometimes. Friday before last I left the bank and was
    headed up the street when all of a sudden my truck died
    on me. I coasted into a parking lot and put it into park
    and hit the switch and it started right up. Then yesterday
    I was out and about when I saw a friend and pulled into
    a parking lot to shoot the bull with him. We had been talking
    about 10 min. when all of a sudden my truck died again.
    I hit the switch and it started right up again but only ran
    for about 2 min. and died again. So I desided to leave,
    went out on the street and made it about 50 yards when
    it started jerking and cutting out. I pulled into a parking
    lot and it went dead. I hit the switch and it started right
    up, I relved (sp?) the piss out of it and it ran fine all the
    way back home. On both days that it quit on me the gas
    gauge showed that I had around a 1/4 of a tank of gas
    left in it. When I filled the tank up it runs fine! I had the
    recomended fuel system flush done to it back in the
    first part of the spring. I seems like it's starving for gas
    when it goes dead. Has anyone else had this problem or
    think they may know what's wrong with my truck?

    Sorry for the long post!
    I'm better than some but not as good as other's!
    1985 s10 V8 Bitch
    http://www.cardomain.com/ride/2171380

  2. #2
    oaktowntrucks.com chizwizdiz's Avatar
    Join Date
    May 2004
    Location
    Utica, MI
    Posts
    626
    how many miles are on it? Maybe it needs a fuel filter, or your guage is way off and when you see a 1/4, its really low.
    Yahell-chizwizdiz
    AIM-chizl00

  3. #3
    woo!! dancey dancey!! Boink's Avatar
    Join Date
    Oct 2001
    Location
    Streator Illinois
    Posts
    4,018
    is it a 2.2??? The fuel pressure regulators will do that. They fail on many 2.2's it isnt uncommon.
    Im2Drunk2C: well bro i gotta run, work time
    Im2Drunk2C: later
    B o I k 2 0: alright
    B o I k 2 0: before you go tho
    B o I k 2 0: I love you
    Im2Drunk2C: awwww
    Im2Drunk2C: <3

  4. #4
    Camel Toe Inspector junky2's Avatar
    Join Date
    Jan 2004
    Location
    Georgia
    Posts
    220
    It's got just a little less than 40,000 on it, and
    it has the 4.3L engine in it. I have an extended
    warranty good for 75,000 miles, so I'm going
    to take it to the dealership tomorrow. I was
    just wondering if anyone else had this same
    problem or knew what it could be. I have
    a feeling it has something to do with my
    gauge.
    I'm better than some but not as good as other's!
    1985 s10 V8 Bitch
    http://www.cardomain.com/ride/2171380

  5. #5
    Angry Black Man Robo's Avatar
    Join Date
    Sep 2003
    Posts
    637
    My needle bounces around when it is around 1/4 tank...hvent quite narrowed it down.
    Prepare for the worst, pray for the best; if you do, then you will ALWAYS be ready for anything! Faith ALWAYS overrides fear!

  6. #6
    Positively Negative
    Join Date
    Jan 2004
    Location
    York, SC
    Posts
    1,012
    Originally posted by Robo
    My needle bounces around when it is around 1/4 tank...hvent quite narrowed it down.


    my moms '98 does that ... im assuming it is the sending unit

  7. #7
    Camel Toe Inspector junky2's Avatar
    Join Date
    Jan 2004
    Location
    Georgia
    Posts
    220
    The dealership replaced the sending unit in
    my truck back in May because I told them
    that my Fuel Gauge floated like crazy when
    it was around 1/4 tank.
    I'm better than some but not as good as other's!
    1985 s10 V8 Bitch
    http://www.cardomain.com/ride/2171380

  8. #8
    Camel Toe Inspector junky2's Avatar
    Join Date
    Jan 2004
    Location
    Georgia
    Posts
    220
    The latest!

    I took my truck to the dealership this morning
    and they checked it out. When the tech. hooked
    the computer to it he said that it was showing
    all kinds of codes. After about 3 hours of them
    working on it, they narrowed it down to being
    an enternal problem. The tech. said that #1 & 4
    cylinders were miss firing and he was going
    to have to remove the whole fuel system on
    the engine.

    Think God for my Extended Warranty!
    I'm better than some but not as good as other's!
    1985 s10 V8 Bitch
    http://www.cardomain.com/ride/2171380

  9. #9
    Camel Toe Inspector junky2's Avatar
    Join Date
    Jan 2004
    Location
    Georgia
    Posts
    220

    Update

    Well I got my truck back yesterday and the
    dealership told me that after $2000 in parts
    and labor they still don't have it fixed. They
    got it running well enough so that I could have
    it for the weekend, but I'll have to take it back
    next week. The dealership thinks that the fuel
    injection system is screwed-up and their going
    to swap all of it out next week.
    I'm better than some but not as good as other's!
    1985 s10 V8 Bitch
    http://www.cardomain.com/ride/2171380

  10. #10
    OST Co-Founder BlazerLT's Avatar
    Join Date
    Sep 2003
    Posts
    369
    They're dumbasses.

    I guarantee the tank was empty and the sending unit is out of whack.

  11. #11
    Camel Toe Inspector junky2's Avatar
    Join Date
    Jan 2004
    Location
    Georgia
    Posts
    220
    I thought the same thing until I filled it
    up and the very next morning and it stalled
    3 times and it cut-out on me all the way
    to the dealership. At times I couldn't get
    it to get over about 10 MPH. The dealership
    said that GM has a Service Bulletin out that
    says that the timing chain cover could worp (sp?)
    causing the cam senser to not touch the cam
    button thus causing it to miss fire on numbers
    1, 4, or 6 cylinder. The dealership fixed that
    but it still doesn't run right.
    I'm better than some but not as good as other's!
    1985 s10 V8 Bitch
    http://www.cardomain.com/ride/2171380

  12. #12
    OST Co-Founder BlazerLT's Avatar
    Join Date
    Sep 2003
    Posts
    369
    Ah, I missed that part.

    Let them keep paying for it. And make sure they warranty the work they do on top of the warrantee you already have.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •