Page 2 of 2 FirstFirst 12
Results 16 to 26 of 26

Thread: truck died at 60mph?

  1. #16
    OST Co-Founder BlazerLT's Avatar
    Join Date
    Sep 2003
    Posts
    369
    Grounds for sure or your black ignition module on the steering column has a bad solder joint. (The pink wire)

    Hope it doesn't happen again, electrical gremlins are a bitch.

  2. #17
    Beer Pong Champs! FeTTo's Avatar
    Join Date
    Mar 2002
    Location
    North Jerzy
    Posts
    6,870
    nope hasnt happened since then, i just dont worry about it anymore

    94 4dr 2wd jimmy - GONE!!
    98 4dr 4x4 blazer- GONE
    06 colbalt ss 4dr - GONE
    2012 Ram Sport 1500 QC

    4 Door Love

  3. #18
    Switchcraft Customs DJ Nitrous 427's Avatar
    Join Date
    Feb 2004
    Location
    Albany, GA
    Posts
    548
    my truck did the cut-off thing i was tlkin bout earlier when i hit 95 today
    Premier 880PRS
    ARC PEQ 7 (Silver Edition)
    ARC KAR 265 Componets
    ARC KAR 6932 6x9s
    15" RE Destroyer in 5 cubes @ 27hz

  4. #19
    OST Co-Founder BlazerLT's Avatar
    Join Date
    Sep 2003
    Posts
    369
    That is the engine cut off speed limiter.

  5. #20
    Switchcraft Customs DJ Nitrous 427's Avatar
    Join Date
    Feb 2004
    Location
    Albany, GA
    Posts
    548
    naw i've hit my govenor at 100 many times b4...this time (and its happened previously)..all the electronics will shut off for a sec then come back on gauges...gauge lights...headlights...stereo
    Premier 880PRS
    ARC PEQ 7 (Silver Edition)
    ARC KAR 265 Componets
    ARC KAR 6932 6x9s
    15" RE Destroyer in 5 cubes @ 27hz

  6. #21
    OST Co-Founder BlazerLT's Avatar
    Join Date
    Sep 2003
    Posts
    369
    Make sure all your computer connections are tight.

    For the love of god, 100mph in a Blazer is a little scary.

  7. #22
    Eagles JPMasters1107's Avatar
    Join Date
    Jan 2003
    Location
    Philadelphia
    Posts
    1,277
    i got 4 gauge wire from my alt to battery and a 4 gauge ground on the battery...no problems

  8. #23
    OST Co-Founder BlazerLT's Avatar
    Join Date
    Sep 2003
    Posts
    369
    what are you talking about?

  9. #24
    Switchcraft Customs DJ Nitrous 427's Avatar
    Join Date
    Feb 2004
    Location
    Albany, GA
    Posts
    548
    Originally posted by BlazerLT
    [BFor the love of god, 100mph in a Blazer is a little scary. [/B]
    Nah...it aint bad...jus dont let it get away from ya...
    Premier 880PRS
    ARC PEQ 7 (Silver Edition)
    ARC KAR 265 Componets
    ARC KAR 6932 6x9s
    15" RE Destroyer in 5 cubes @ 27hz

  10. #25
    OST Co-Founder BlazerLT's Avatar
    Join Date
    Sep 2003
    Posts
    369
    Originally posted by DJ Nitrous 427
    Nah...it aint bad...jus dont let it get away from ya...
    Yeesh, spooky!

  11. #26
    Senior Member BadBrad469's Avatar
    Join Date
    Jul 2003
    Location
    Highlands TX
    Posts
    1,450
    nah, it's not that bad, i have a 1st gen and i've done about 115-120 in mine...actually kinda fun in a blazer....just hope no one pulls out in front of u :-P

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •