Page 1 of 2 12 LastLast
Results 1 to 15 of 17

Thread: 1995-2003 S10 & Blazer Front End Clunk Pop Fix!!! Read!!

  1. #1
    OST Co-Founder BlazerLT's Avatar
    Join Date
    Sep 2003
    Posts
    369

    1995-2003 S10 & Blazer Front End Clunk Pop Fix!!! Read!!

    Guys,

    I thought I found that the sway bar bushings were causing my front end passenger clunk and popping but guess what, they weren't.

    Before I drop the bomb and show what I learned through scouring the internet, I have replaced the following:

    Lower Ball Joints
    Passenger Upper Ball Joint
    Sway Bar End Links (Had to be replaced Anyways)
    Sway Bar Bushings
    Front and Rear Shocks

    Total bill: ~US$600

    After all of that, it wasn't even the problem. There is a service bulletin that talk about this in this upcoming video.

    Want to know what the clunk is? Here you go!



    Remove this 7mm screw holding the small outer cowl inserts over the hinges. Close the hood.

    Remove the covers carefully and don't break the clips.

    The hingles will be attached and they are a 13mm nut and bolt.

    http://www.tweaknews.net/decarbon/clunkfix.AVI <----Right Click, Save As

    That's right, a $2 dollar part fixes this problem that has pissed so many Blazer owners off.

    This is the service bulletin that came out in 2001 I believe. Covers all S10 and Blazers.

    http://www.zr2.com/frequently_asked_.../clunking.html

    Scroll Down to Rattle.

    There you have it, I temporarily laid a couple bunched up shop towels under the flat part in the video and went for a drive on the roughest washboard road within 50 miles and never heard a thing.

    Hope you don't go through what I went through.

  2. #2
    Registered User hotrodblazer4.3's Avatar
    Join Date
    Nov 2002
    Location
    Hanover,PA
    Posts
    372
    Excellent information. Very nicely presented. I really wish more members could be as helpful.
    The above opinion is my own and is subject to ridicule since age and experience mean nothing on these forums.

  3. #3
    OST Co-Founder BlazerLT's Avatar
    Join Date
    Sep 2003
    Posts
    369
    Your welcome.

    This is the solution to the clunking everyone is hearing in either the driver's or passeenger front when going over bumps etc.....

    Install the spring washers and you will be fixed.

  4. #4
    Eat.Sleep.Lift...repeat EmptyPockets's Avatar
    Join Date
    Jun 2003
    Location
    East Side
    Posts
    6,498
    is it the clunk that sounds like its coming from right below the pedal area? I get a clunk when I am stopped and then acceralte most of the time...you think its the same shit?

  5. #5
    Eat.Sleep.Lift...repeat EmptyPockets's Avatar
    Join Date
    Jun 2003
    Location
    East Side
    Posts
    6,498
    THIS NEEDS TO BE STICKY'D!!!!!!!!!!!!

  6. #6
    OST Co-Founder BlazerLT's Avatar
    Join Date
    Sep 2003
    Posts
    369
    Originally posted by EmptyPockets
    is it the clunk that sounds like its coming from right below the pedal area? I get a clunk when I am stopped and then acceralte most of the time...you think its the same shit?
    For the 5minutes it takes, I would check it out just to be sure.

    Mind sounded like it was coming from the passenger foot area and it was the hood.

    New washers are in and everything is SILENT! Like a new truck...


    I am SOOOO HAPPY!!!:bigthumb:

  7. #7
    Registered User
    Join Date
    Jul 2004
    Location
    Benfleet 30 miles eastof London
    Posts
    140
    does this apply to my 89 blazer as i have a similar noise from the drivers side.

  8. #8
    OST Co-Founder BlazerLT's Avatar
    Join Date
    Sep 2003
    Posts
    369
    Sure, see if your hood hinge is loose.

    You have to go out and wiggle it like I did to see.

  9. #9
    Registered User loblzr's Avatar
    Join Date
    Jun 2002
    Location
    Outside Houston TX
    Posts
    519
    Awesome, I developed that same problem after my last paint job (we had the hood off). I thought it was inside my door since i did the upholstery at the same time, Thanks alot for the research and part #'s.

    http://www.cardomain.com/id/1loblzr

    3rd place Texas Heatwave 02 Mini SUV street, 1st place Texas Showdown 03 SUV Street, 2nd place Texas Heatwave 03 Mini SUV Full modified, 1st Place Rollout 2K3 SUV mild, 2nd place Houston Autorama semi mini sport wagon, 2nd place Dustoff 04 SUV Wild, 3rd lakefront tour 04, 1st heatwave 06, 2nd Dustoff 06

  10. #10
    OST Co-Founder BlazerLT's Avatar
    Join Date
    Sep 2003
    Posts
    369
    Originally posted by loblzr
    Awesome, I developed that same problem after my last paint job (we had the hood off). I thought it was inside my door since i did the upholstery at the same time, Thanks alot for the research and part #'s.
    No problem, I love when my help is appreciated.

  11. #11
    Registered User Blazen1990's Avatar
    Join Date
    Aug 2006
    Location
    california
    Posts
    95
    Wow let me check that out mine is making the same sound. I was thinking it might be the bushings.
    Thanks BlazerLT
    1990 Blazer 4.3 v6
    1996 Blazer 4.3 v6 Gone :(

  12. #12
    Banned
    Join Date
    Nov 2002
    Location
    Lyndon, Kansas
    Posts
    7,511
    ok my buddy with a 97 s10 had this problem and tried this last year but the hole is worn out. if you put a nut and bolt in it work pivit of course. what do you do then?


    89' S10 blazer 4wd: 355, 650 dp, rpm intake, comp 282 roller cam, modified vortecs, T56 Six speed, 8.8 ls rear, headers, x-pipe, spintech pro street mufflers, and......AC

    Blazer burnout video - http://www.youtube.com/watch?v=sP7iLypoDI4

  13. #13
    My blazer is my other job 1998BlazeUp's Avatar
    Join Date
    Apr 2007
    Location
    Massachusetts
    Posts
    198
    damn i cant see the movie it only plays in audio form
    http://www.cardomain.com/ride/2587692/1
    :whogives:
    peep the ride sign the guestbook!

    Howz that fools?

  14. #14
    Registered User 03dirtydime's Avatar
    Join Date
    Oct 2006
    Location
    Alabama
    Posts
    86
    Same thing here
    Too many mods to list :D
    www.cardomain.com/ride/2293608

  15. #15
    FireFighter/EMT Spyderman358's Avatar
    Join Date
    Jul 2005
    Location
    Erie, PA
    Posts
    113
    have to upgrade quick time guys!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •