Results 1 to 3 of 3

Thread: Oil Pressure??

  1. #1
    Registered User
    Join Date
    Jun 2005
    Location
    Bay Area (510)
    Posts
    4

    Oil Pressure??

    If anyone has any ideas, My 90 S-15 Jimmy oil guage will show good oil pressure at ilde and while driving, But when i am coming to a stop and take off my oil pressure will drop low, sometimes it will even drop to nothing and the light will flash. Then it will imediatly jump back to great oil pressure 50-60 psi. Even sometimes when i am driving on the freeway it has done it while crusing but more often when stopping and going????
    Please help, not sure where to start.....

  2. #2
    BLF #1 BITCHES! slow 89's Avatar
    Join Date
    Jun 2002
    Location
    south jersey
    Posts
    5,769
    start by checking your oil level.. if thats good and its still acting up then replace the oil pressure sending unit.. that should fix your problem.. usually they get gummed up or a piece of debris gets stuck in the sender and it dosent read correctly
    WWW.HAGGARDFAB.COM

    //NC\\
    Negative Camber

  3. #3
    Registered User
    Join Date
    Jun 2005
    Location
    Bay Area (510)
    Posts
    4
    thanks, the oil level is good so i will try the sending unit, if anyone else has any ideas too, I will let you know if the sending unit helps thanks again

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •