Results 1 to 10 of 10

Thread: 00 s10, bad fuel pump and sending unit?

  1. #1
    BL Metalhead thechariot's Avatar
    Join Date
    Nov 2004
    Location
    st. louis
    Posts
    2,539

    00 s10, bad fuel pump and sending unit?

    so, tonight i was driving my bros s10, and all of a sudden,..i slow to a stop, it kinda shakes, and dies. the battery light comes on and lights ang everything elecrtical works...i started it back up...drove maybe 1/2 mile, did it again, drove to blockbuster which was the nearest thing by, it dies again. now it wont even start...is this the fuel pump? if so where can we get one relatively cheap. and the sending unit, like vortech's thread...it ALWAYS reads empty...but i dunno if im gonna worry about that one..

    but will a shot of ether help it start back up to get it home?
    92 blazer 4 door 4.3 2wd, 00 s10, 03 accord v6


    Originally posted by 668
    I fuckin popped her, held back a little, but I clipped her pretty good.


  2. #2
    The Baby Seal Says: drewdaddyblazin's Avatar
    Join Date
    Oct 2001
    Location
    Moore, Oklahoma
    Posts
    1,957
    Hmm yes check that... check the ignition too...

    Tomorrow go out, have one guy listen for the fuel pump to make a noise to prime up the system... he will sound like a little eletricmotor... no sound, definatly thef uel pump..
    Well you probably know what youre lookin for youre not a noob..

    take the plug out of a cylinder and stick a screw driver in teh plug, when youre cranking the motor see if it sparks!

    If it doesnt, start checking the rotor and distributor cap, the gnition coil

    we will go from there
    (08:25:41 PM) AndySeals355: shes one of those jesus loves everyone types lol
    (08:25:42 PM) Zachary188: when she's ontop you'll have the cross necklace hitting you in the face!
    (08:25:49 PM) AndySeals355: LMFAO

  3. #3
    BL Metalhead thechariot's Avatar
    Join Date
    Nov 2004
    Location
    st. louis
    Posts
    2,539
    its the fuel pump...we figured that much out.

    where to get one that doesnt cost 300 frggin dollars...so says my brother.
    92 blazer 4 door 4.3 2wd, 00 s10, 03 accord v6


    Originally posted by 668
    I fuckin popped her, held back a little, but I clipped her pretty good.


  4. #4
    The Baby Seal Says: drewdaddyblazin's Avatar
    Join Date
    Oct 2001
    Location
    Moore, Oklahoma
    Posts
    1,957
    god damn 300?

    look around online theres probably an online parts shop

    well hell tell him to go to a salvage yard...

    www.car-part.com

    i love that website...
    (08:25:41 PM) AndySeals355: shes one of those jesus loves everyone types lol
    (08:25:42 PM) Zachary188: when she's ontop you'll have the cross necklace hitting you in the face!
    (08:25:49 PM) AndySeals355: LMFAO

  5. #5
    BL Metalhead thechariot's Avatar
    Join Date
    Nov 2004
    Location
    st. louis
    Posts
    2,539
    150...not bad. thanks drew.
    92 blazer 4 door 4.3 2wd, 00 s10, 03 accord v6


    Originally posted by 668
    I fuckin popped her, held back a little, but I clipped her pretty good.


  6. #6
    The Baby Seal Says: drewdaddyblazin's Avatar
    Join Date
    Oct 2001
    Location
    Moore, Oklahoma
    Posts
    1,957
    Yah i got my windsheild from a salvage yard for 50 bucks i found on that site...

    neat huh... Ghetto junk yards are startin to be HIGH TECH UHUAHD lkam
    (08:25:41 PM) AndySeals355: shes one of those jesus loves everyone types lol
    (08:25:42 PM) Zachary188: when she's ontop you'll have the cross necklace hitting you in the face!
    (08:25:49 PM) AndySeals355: LMFAO

  7. #7
    punch your face catch's Avatar
    Join Date
    Jul 2002
    Location
    British Columbia
    Posts
    1,131
    does the fuel pump come on at all?

    and just out of curiosity.. will it stay running if you give it gas?

  8. #8
    BL Metalhead thechariot's Avatar
    Join Date
    Nov 2004
    Location
    st. louis
    Posts
    2,539
    itll run for like 5 seconds as i rev it. then die.
    92 blazer 4 door 4.3 2wd, 00 s10, 03 accord v6


    Originally posted by 668
    I fuckin popped her, held back a little, but I clipped her pretty good.


  9. #9
    woo!! dancey dancey!! Boink's Avatar
    Join Date
    Oct 2001
    Location
    Streator Illinois
    Posts
    4,018
    if all the electrical come on isnt that a alternator?
    Im2Drunk2C: well bro i gotta run, work time
    Im2Drunk2C: later
    B o I k 2 0: alright
    B o I k 2 0: before you go tho
    B o I k 2 0: I love you
    Im2Drunk2C: awwww
    Im2Drunk2C: <3

  10. #10
    pulls out baggie...smiles 98inthedirt's Avatar
    Join Date
    Jul 2005
    Location
    southern Illifreackinois
    Posts
    160
    my blaze did the same thing and i found a fuel pump for 15 bucks in a junkyard in indiana (evensville) they got alot of cheap crap there the name is (librity pull-a-part) anyways after i got the new pump i learnd that the problem was realy in the factory wireing harness and that it was a common problem, it took hours to find but it was a simple short in a wire, so i sold my extra pump for 70 bucks (good deal) what im tring to say here is that it my not be your pump but the wires that run to it, it would be easier if it is the pump though

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •