Page 1 of 3 123 LastLast
Results 1 to 15 of 37

Thread: engine stops rotating at 180 degrees

  1. #1
    Registered User
    Join Date
    Feb 2006
    Location
    bethlehem pa,
    Posts
    49

    Cool engine stops rotating at 180 degrees

    waz up peeps new here. my 95 blazer vortec is hell for me
    installed a new cpi now my engine only turns 180 degreeswhen im manually turning the crankshaft in any
    direction. its been sitting for 9 months but even so this never happend. i put everything into this truck thinking that i solved the problem and the whole time it was the cpi. can someone please help me out.

    blazin1925

  2. #2
    has no subtitle. ColonelPanic's Avatar
    Join Date
    Jul 2005
    Location
    West Warwick, RI
    Posts
    713
    Honestly I have no idea. But welcome to the forum! I see your accually nearby. See ya around

  3. #3
    Registered User sbcs15's Avatar
    Join Date
    Nov 2002
    Location
    Denton Tx
    Posts
    338
    did you do any other work to the engine, like timing chain?

    also try to pull your distributer out and try to turn it, it could have locked up
    NOS is like a hot chick with a STD, You know you want to hit but your afraid of the consequences!

  4. #4
    It's all about to change winditup57's Avatar
    Join Date
    Oct 2005
    Location
    Davenport, IA
    Posts
    2,064
    If it will only turn 180 degrees...something is broke or bent
    ______________________________
    You dont grow out of stupid...you have it for life.
    Build 'em light and wind 'em tight!!
    1980 Malibu Classic 2 DR

  5. #5
    . CBZED101's Avatar
    Join Date
    Aug 2002
    Location
    San Antonio, TX
    Posts
    4,211
    I dont have a CPI motor but is it possible that mabye you dropped something down inside the engine while you were replacing the CPI?

  6. #6
    Registered User
    Join Date
    Feb 2006
    Location
    bethlehem pa,
    Posts
    49
    thanks the for the rapid response, well i did the timing chain, complete cpi nut kit, spider unit and intake job. new ignition, alternator, could this be because the truck sat for quite some time

  7. #7
    It's all about to change winditup57's Avatar
    Join Date
    Oct 2005
    Location
    Davenport, IA
    Posts
    2,064
    Ok..what is a CPI....not up on the newer shit...I am a carb man myself....K.I.S.S.
    ______________________________
    You dont grow out of stupid...you have it for life.
    Build 'em light and wind 'em tight!!
    1980 Malibu Classic 2 DR

  8. #8
    My avalanche,totaled 8( POSblazer's Avatar
    Join Date
    Jun 2005
    Location
    Pensa~cola,Fl.
    Posts
    931
    Originally posted by blazin1925
    thanks the for the rapid response, well i did the timing chain, complete cpi nut kit, spider unit and intake job. new ignition, alternator, could this be because the truck sat for quite some time
    Yes, A little bit of surface rust may of formed on the cylinder walls, wich could keep it from turning.
    CPI= Central Port Injection- Central Point Injection. A GM fuel injection system that uses a centralized fuel injector delivering fuel through lines to injector nozzles located at each cylinder
    I had to look it up just to be sure :p:
    Last edited by POSblazer; 02-04-2006 at 01:18 AM.
    Update:My avalanche was totaled by my ex-gf. My business is in ruins. I now plan on finishing the engine repairs to my Saturn, and sell it. Once I get the bills paid off, I'm going to fix my Blazer.
    History:I bought a 2001 saturn sc2, then a 2005 avanche 1500 2wd, then a '87 S10 blazer 2dr 2wd on 07/24/2010, and on 04/01/2011 a '84 s10 blazer 2dr 2wd V8 drag racer(sort of)

  9. #9
    Registered User
    Join Date
    Feb 2006
    Location
    bethlehem pa,
    Posts
    49
    well before i did the intake job i didnt have this problem
    so im not sure if i should take it all off or not, would the order of the injectors have anything to do with this problem, someone told me if i get fuel in the pistons that it would cause this problem but im not sure. this dam truck is driving me f=====ing crazy

  10. #10
    Registered User
    Join Date
    Feb 2006
    Location
    bethlehem pa,
    Posts
    49

    Angry

    well im pist right about now but im gonna kick this in the ass thanks much for the help guys talk to you tomorrow fellas

  11. #11
    . SlimJimmy's Avatar
    Join Date
    Oct 2002
    Location
    Edmonton. Canada
    Posts
    4,012
    If your timing chain is setup right, and you havent dropped anything in it, have you tried starting it? It MAY just be rust like mentioned....although, if it doesnt feel just like friction from rust, it will be something bent or broken, and it could be pretty much anything, rod, broken piston, busted rungs, timing chain, timing gear,pushrods, lifters....

  12. #12
    Registered User
    Join Date
    Feb 2006
    Location
    bethlehem pa,
    Posts
    49
    well the timing chain is ok ive put a lot of money into this b-t---ch
    when i turn the crank i keep my eye on the rotor and it will only go from the number one spark plug marking over to the opposite end and then the crand comes to a dead stop

  13. #13
    Registered User
    Join Date
    Feb 2006
    Location
    bethlehem pa,
    Posts
    49
    well i guess im just gonna have to take everything off again so i could double check everything i did

  14. #14
    The Baby Seal Says: drewdaddyblazin's Avatar
    Join Date
    Oct 2001
    Location
    Moore, Oklahoma
    Posts
    1,957
    Thts a good idea man... Just dont try to start it, it will break something! Im sure you realize that but when you get pissed youll do silly stuff...

    Heres what youre probably going to have to do..
    Take the whole thing apart. Take the CPI manifold off, and take your valve covers off. TAke a flash light and see if anything is down i the heads. Look to make sure you dont have a bent push rod or anything wrong in the valve train. If there is still nothing, youre might just have to take the heads off.

    Hey there may be a bright side to this! While you got the heads off, replace the head gaskets! They are probably wore out anyway.Who knows, you might have gotten this thing together all running but blow a head gasket 3 months later...

    Bad stuff happeend to me when i was puting my motor in. But in the end, it turned out to be a good thing! (has to do with main bearings)

    Anyways good luck man and post up what you find..

    -drew
    (08:25:41 PM) AndySeals355: shes one of those jesus loves everyone types lol
    (08:25:42 PM) Zachary188: when she's ontop you'll have the cross necklace hitting you in the face!
    (08:25:49 PM) AndySeals355: LMFAO

  15. #15
    Registered User
    Join Date
    Feb 2006
    Location
    bethlehem pa,
    Posts
    49
    well heres the thing once i get the #1 piston up to top dead center it stops a hair from the marker and then i cant pull the crank by hand, but if i turn the key to crank it the engine then it turns the rest of the way. what do you think about that

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •