Results 1 to 8 of 8

Thread: all cylenders misfiring?

  1. #1
    Registered User 02xtremeblaze's Avatar
    Join Date
    May 2006
    Location
    Beech Grove IN
    Posts
    99

    all cylenders misfiring?

    My truck has had the sevice engine light on since about a week after i bought it. I took it to a family friend to diagnose it, he said that all of my cylenders are misfiring, he put a new cap and rotor on it and the light is still on.....anyone else have this happen? easy fix or am i screwed?
    i would love to know what is wrong with my truck....thanks Mike
    http://www.cardomain.com/ride/2424845

    http://www.myspace.com/8404004

  2. #2
    Ultra Flat Black Member 88S10_Blazer's Avatar
    Join Date
    Jan 2003
    Location
    Vernon, NJ
    Posts
    1,733
    all cylinders at the misfiring would mean that they are firing at the wrong time. the cap and rotor would only help the spark get stronger, not change when anything fires. if they are all consisitently at the wrong spot, your timing is off. grab a timing light and check that first.
    Carl.

    if you didn't build it with your own two hands, its not really yours.

    http://www.myspace.com/7711952

  3. #3
    SIk Addictions
    Join Date
    Jul 2005
    Location
    Central,Florida
    Posts
    1,331
    Check you O2 sensors mine has had the CEL on for a wile with a code of 4xx I can't remember but it said I had a misfire on 1,3,and 5 I was told that is was not a misfire just bad O2's my cat is shot so I'm fairly sure thats what caused it.

  4. #4
    Registered User 02xtremeblaze's Avatar
    Join Date
    May 2006
    Location
    Beech Grove IN
    Posts
    99
    Originally posted by 88S10_Blazer
    all cylinders at the misfiring would mean that they are firing at the wrong time. the cap and rotor would only help the spark get stronger, not change when anything fires. if they are all consisitently at the wrong spot, your timing is off. grab a timing light and check that first.

    That is what dad said, im going to check that out after work....
    http://www.cardomain.com/ride/2424845

    http://www.myspace.com/8404004

  5. #5
    Registered User 02xtremeblaze's Avatar
    Join Date
    May 2006
    Location
    Beech Grove IN
    Posts
    99
    Originally posted by keepinitsimple
    Check you O2 sensors mine has had the CEL on for a wile with a code of 4xx I can't remember but it said I had a misfire on 1,3,and 5 I was told that is was not a misfire just bad O2's my cat is shot so I'm fairly sure thats what caused it.
    I thought it was an o2 sensor all along, how much did those sensors cost? are how many are on my truck?
    http://www.cardomain.com/ride/2424845

    http://www.myspace.com/8404004

  6. #6
    Resident Geek el guapo's Avatar
    Join Date
    Feb 2002
    Location
    Newark, DE
    Posts
    1,905
    o2 sensors are fairly cheap - you can get off-brand ones at AutoZone for like $50, but do yourself a favor, and just get the ACDelco ones.

    I'm not so sure an o2 sensor would cause misfiring - they control the rich/lean mixture. Get your SES light codes and post them up - that should give you an indication of where to start...

  7. #7
    Ultra Flat Black Member 88S10_Blazer's Avatar
    Join Date
    Jan 2003
    Location
    Vernon, NJ
    Posts
    1,733
    if its not the timing, check the plug wires too. they could be shot and arcing to each other if they are touching
    Carl.

    if you didn't build it with your own two hands, its not really yours.

    http://www.myspace.com/7711952

  8. #8
    Registered User syclonekid43's Avatar
    Join Date
    Jan 2003
    Location
    ct
    Posts
    5,314
    there is a chance the valves are hanging up on you. we had a second gen here and it would say it had missfire. we did a full tune up and it was still the same. come to find out there was a problem with these heads that GM knows about. the valve guides are the problem. heads need to be machined a bit to open up the valve guides.

    not sayin that is your problem,but anything can happen.
    91 GMC SYCLONE(fast),88 2wd blazer(old school and sold),88 S-10 BLAZER(sold),92 4dr 2wd blazer(pink and bagged)93' s-10 blazer(plow truck),88 GTA TUNE PORT(blown motor),97 MXZ 670,01 YAMAHA RAPTOR(sleeping),87 YSR 50 CC WITH A 125 CC(never be done)
    THE SURGEON GENERAL WARNING NEVER SAID ANYTHING ABOUT SMOKING A FORD

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •