Results 1 to 4 of 4

Thread: Problem need help....

  1. #1
    GOT mine, GOT Yours? GotMy4Door's Avatar
    Join Date
    Jul 2006
    Chicago, IL

    Question Problem need help....

    Ok so driving my 1998 4x4 jimmy today with stock suspension.

    im noticing some clicking noise comming from the floor assuming its something with the axles a guy said prolly the cv axles.

    What are my options to fix or quik fix or just take care of it totally? i dont have any experience with 4x4 like this. thanks in advance! (also tryn to save money)

  2. #2
    damn low dragging 4x4
    Join Date
    Oct 2001
    if its the cv shaft just replace it. like $80 for a new one with an $80 core charge at autozone.
    president: Lower Level Customs car and truck club
    90 BLAZER 4.3 4x4 dropped 7" fully shaved with full size chevy tails, 98 Honda accord ground effect, 2 inch cowl hood, truxarossa grill and mirrors, metal flake and yellow flamed paint job, molded wing, too much to list( back under construction! new front end to come... out with the fiberglass back with the metal!)
    87 blazer: 2wd under construction

  3. #3
    '93 Typhoon / 97 Isuzu C-Town216's Avatar
    Join Date
    Jan 2002
    Cleveland, Ohio


    If the rubber acordian popoid boot on the front drive axles ain't torn or leaking grease N E than check the rubber mounts where the torsion bar cross member bolts to the frame.
    "All I need iz 1 mic"

  4. #4
    Join Date
    Nov 2002
    Lyndon, Kansas
    yeah, if they are clickin their too far gone, get some new ones.

    89' S10 blazer 4wd: 355, 650 dp, rpm intake, comp 282 roller cam, modified vortecs, T56 Six speed, 8.8 ls rear, headers, x-pipe, spintech pro street mufflers, and......AC

    Blazer burnout video -

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts