Page 4 of 4 FirstFirst ... 234
Results 46 to 55 of 55

Thread: just picked up a 96 blazer...

  1. #46
    Fully Erect Member
    Join Date
    Jul 2005
    Location
    Connecticut
    Posts
    215
    Quote Originally Posted by ride and destro View Post
    you could be shaving the wieghts off your rims, i had that issue myself, take the wheel off and look for abraisions or anything that could be obstructing the wheel.
    in some applications i'd see that possible but i have a hard time seeing it due to having stock wheels

  2. #47
    Registered User
    Join Date
    Jan 2005
    Location
    South Miami
    Posts
    128
    could it be the CV joints?
    when i go to get the tranny flushed ill have them scope it out and see what they say.

  3. #48
    Fully Erect Member
    Join Date
    Jul 2005
    Location
    Connecticut
    Posts
    215
    pleas do not ask them to look at your CV joints, most places will try to sell you stuff and take your money, your truck does not have CV joints

  4. #49
    Registered User
    Join Date
    Jan 2005
    Location
    South Miami
    Posts
    128
    hmf.

    what should i ask them to take a look at then?

  5. #50
    Registered User
    Join Date
    Jun 2007
    Posts
    3
    I have the same truck in 4dr and i had no heat but no water on the floor. I took off the heater core hoses on the firewall under the hood and reverse blow with water it was full of crap. If you have anti-freeze in your cooling system you should be able to smell it if the water on the floor is coming from your heater core. Plus if you are having to top up your rad all the time then you may have a leek. Lift up the carpet on Pass floor and let truck run with heat full blast. Make sure you run long enough to open thermustat and watch for any water coming down from under dash on pass side. After you flush out the heater core you should burp it. Let run with front end much higher then rear with cap off rad and heat on, after thermo opens make car lever and top up rad.. This what I did to mine and all works like new now..

  6. #51
    long member bigdawg's Avatar
    Join Date
    Oct 2001
    Location
    Butler, KY
    Posts
    1,404
    your frontend pop is most likely one of the following:



    tie rod ends
    ball joints
    steering box may be loose from frame

    that is what i would check first.;)
    2000 Red Dime sitting low.and pretty.

  7. #52
    Registered User
    Join Date
    Jan 2005
    Location
    South Miami
    Posts
    128
    the pop in the steering was from a upper control arm bushing. i got it replaced now i dont have that problem.
    now whats left is the heater core issue which ill get to later when funds allow.

    i used this stuff called aqua mend to stop the leak. its like a putty you mix with your hand and pack into the leaky spot. its used on boats n shit or where water is present. now it started leaking again behind this wire harness, which is a pita to get to.

    is there any way to get that off? i tired but couldnt, cause i didnt want to break any clips. im thinking ill have to take the fender off to completly rid of the leak. even though its not half as bad as it was before, i cant run any wire back with the carpet being wet.

  8. #53
    Resident Mustang Guru pickardracing's Avatar
    Join Date
    Feb 2006
    Location
    Two Rivers, WI
    Posts
    70
    SOunds to me like you're chasing something that isnt there.

    Stick a airgun in that heater core and blow all the water out of it. I can almost guarantee you thats what your leak is. If it's leaking (which is almost a given by the bypass job) and theres fluid in it, its going on your floor.

    As far as the rest of the rust, you were fine with the undercoating. You'll be 100 years old before you will need to worry about that. Cover it up and be done.

    The front end noise could be 1000 different things. Brakes, tires, front suspension components, etc. Need more info.
    94 Mustang GT Vert
    95 Blazer 4D 4X4

    Click here for my CarDomain Site

  9. #54
    Member biggcheif's Avatar
    Join Date
    Jan 2006
    Location
    Delmar, Iowa
    Posts
    325
    what more info do u want he said it was a upper control arm bushing that he fixed...noise gone :D :smoker:
    Stroke ME!!!:D :smoker:
    1986 2dr 2WD S10 Blazer
    1989 E/C 4WD S10 P/U
    1995 E/C 2WD Silverado
    1994 Chevrolet Beretta
    1997 Hyundai Elantra

  10. #55
    Resident Mustang Guru pickardracing's Avatar
    Join Date
    Feb 2006
    Location
    Two Rivers, WI
    Posts
    70
    Didnt see that.
    94 Mustang GT Vert
    95 Blazer 4D 4X4

    Click here for my CarDomain Site

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •