Results 1 to 5 of 5

Thread: Please help

  1. #1
    Kinger / / GMC \ \'s Avatar
    Join Date
    Feb 2007
    Location
    Pa
    Posts
    18

    Please help

    I have a 96 Jimmy and for the life of me can't figure out how to get it running again. I know it's a gas related problem the only way I can get it to start is to throw gas down into the throttle body. Once I do that it runs pretty shitty for about a mintue then it will run like it has no problems at all. If anybody can help I would really appreciate it

  2. #2
    Registered User LowKeyblazer's Avatar
    Join Date
    Jun 2007
    Location
    gr michigan
    Posts
    172
    sounds like low fuel pressure. either bad pump or plogged fuel filter.

  3. #3
    Kinger / / GMC \ \'s Avatar
    Join Date
    Feb 2007
    Location
    Pa
    Posts
    18
    yea i replaced the fuel filter a couple days ago. I lifted up the truck and it started raining of course i think im gonna try the fuel pump tomorrow after work hopefully thats it. ill keep ya updated thank you

  4. #4
    Registered User GOTDUBZ's Avatar
    Join Date
    Sep 2005
    Location
    Columbus
    Posts
    104
    Is the fuel pump kicking on? If not make sure you check to see if its getting power before you change it. Could be as simple as a bad ground.
    Laid out Blazer X!!! :D TwIzTeD iNtEnTiOns- Ohio
    http://s110.photobucket.com/albums/n102/GOTDUBZ/

  5. #5
    Kinger / / GMC \ \'s Avatar
    Join Date
    Feb 2007
    Location
    Pa
    Posts
    18
    I changed it on Saturday and dam if that wasn't it. Truck runs fine now it's a shame because the last one wasn't ven that old. Oh well it's running again I'm happy thank you to everyone who helped

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •