Page 2 of 2 FirstFirst 12
Results 16 to 26 of 26

Thread: 87 2.8 tbi help

  1. #16
    spinldle drop with blocks *Blazin87*'s Avatar
    Join Date
    Nov 2009
    Location
    D-Town colorado
    Posts
    16
    I'm going now to have it checked ill let u know results

  2. #17
    spinldle drop with blocks *Blazin87*'s Avatar
    Join Date
    Nov 2009
    Location
    D-Town colorado
    Posts
    16
    I gave up, I am sending it to the shop on Friday........

  3. #18
    Registered User rtuite's Avatar
    Join Date
    Jul 2009
    Location
    The armpit of Indiana
    Posts
    71
    I had the same issue with a 4.3. We went nuts, because it was "idling" at about 2500-3000 RPM. Turned out it was the large vacuum hose going to the brake booster. It had a split up the backside that was not obvious in normal inspection.
    '88 2 door, 400SB
    see progress here

  4. #19
    spinldle drop with blocks *Blazin87*'s Avatar
    Join Date
    Nov 2009
    Location
    D-Town colorado
    Posts
    16
    Hmmm I need to check that cause my brakes r messin up sometimes I have to slam on the brakes cause it does not wana stop.. or the pedal goes all the way to the floor..

  5. #20
    Registered User blazin_jason's Avatar
    Join Date
    Aug 2009
    Location
    Van Isl, BC, Canada
    Posts
    49
    I recently had a similar issue of sorts. I would suggest disconnecting the IAC and see if that makes any difference. If there is no change then I would suspect that could be the problem.
    85 Blazer 4x4, 350, 3" BL, 33's, project
    89 Jimmy 4x4, needs 350 swap...
    89 Blazer 4x4, 4.3 gf's DD
    90 Jimmy 4x4, 4.3 my DD

  6. #21
    spinldle drop with blocks *Blazin87*'s Avatar
    Join Date
    Nov 2009
    Location
    D-Town colorado
    Posts
    16
    Yea I tried that but still same problem. I noticed some brake fluid leaking from around the master C... is it possible I blew it and could that cause high ide

  7. #22
    spinldle drop with blocks *Blazin87*'s Avatar
    Join Date
    Nov 2009
    Location
    D-Town colorado
    Posts
    16
    Or is it the large vacuum line from the booster?????????

  8. #23
    Administrator Blazin Low's Avatar
    Join Date
    Oct 2001
    Location
    In Front of You
    Posts
    4,704
    I was going to ask you if your brakes were mushy, but I figured you'd mention that.

    but yeah, maybe your brake booster is bad. That could pull major vacuum and make the idle high.

    Try disconnecting the vaccum line from the brake booster and plugging it - use a bolt or something.

  9. #24
    spinldle drop with blocks *Blazin87*'s Avatar
    Join Date
    Nov 2009
    Location
    D-Town colorado
    Posts
    16
    Yea I wish I had a damn garage. But 2mrrw morning that will be the first thing I check.. cause I almost went nuts tryin to figure out what's wrong. I love my lil truck and hate to see I like that lol!!!!:(

  10. #25
    Senior Member blazer_1994's Avatar
    Join Date
    Mar 2004
    Location
    Kentucky
    Posts
    354
    My 2.8 has the same high idle problems thats urs is having. It idles really high but runs great. When I put mine into gear in gravels it just about spins the tires a lil bit. I changed out all my brake stuff recently, wish I changed the booster while i was at it cause I think that may be the culprit.

    Let me know if u find out anything.
    2006 GMC Canyon 2.8 Daily Driver
    1985 s10 blazer project, shaved stuff and 350 combo, eagle alloys 77 series 17's, 8.8 ford rearend

  11. #26
    spinldle drop with blocks *Blazin87*'s Avatar
    Join Date
    Nov 2009
    Location
    D-Town colorado
    Posts
    16
    ok well today i took it to the shop and had it scanned and the computer is not reading the TPS. so i think its new computer time. i think im gna go tomorrow and buy a new one. i also checked the booster and replaced some old crusty vacuum lines so im prayin that the new computer does the job. i well let u guys know what happen.......

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •