Results 1 to 9 of 9

Thread: squeeking noise,no dust shield?

  1. #1
    Registered User kwickez's Avatar
    Join Date
    Aug 2005
    Location
    saco, maine
    Posts
    524

    squeeking noise,no dust shield?

    is a symptom of no dust shields squeeking?brakes are good and not sure what could b causing the problem.

  2. #2
    Registered User wagonmaster's Avatar
    Join Date
    Aug 2009
    Location
    Tucson, AZ
    Posts
    469
    Need some more info...

    What's squeeking? When you brake? Your suspension? Your dash? A dust shield is just that, has nothing to do with brake squeek. When did this start happening? Did you use the anti-squeek grease when you did you brakes?

  3. #3
    Registered User kwickez's Avatar
    Join Date
    Aug 2005
    Location
    saco, maine
    Posts
    524
    it is the brakes.1/2 way through braking is when it happens.had a shop do the brakes,so not sure if they used the grease.the reason i asked of the dust shield was that the last rear 1 broke off and i think it got worse.

  4. #4
    Registered User wagonmaster's Avatar
    Join Date
    Aug 2009
    Location
    Tucson, AZ
    Posts
    469
    Quote Originally Posted by kwickez View Post
    it is the brakes.1/2 way through braking is when it happens.had a shop do the brakes,so not sure if they used the grease.the reason i asked of the dust shield was that the last rear 1 broke off and i think it got worse.
    How the heck did you break that off? I'd check to see if you've got some other damage back there.

  5. #5
    Registered User kwickez's Avatar
    Join Date
    Aug 2005
    Location
    saco, maine
    Posts
    524
    the dust shield?was rusted out and only held on by hopes and dreams lol. the noise happens at mid brakeing.

  6. #6
    Registered User wagonmaster's Avatar
    Join Date
    Aug 2009
    Location
    Tucson, AZ
    Posts
    469
    Well, if everything is that rusty back there then it's time to inspect and see what's going on.

  7. #7
    Registered User fatboys88's Avatar
    Join Date
    Jan 2010
    Location
    Richmond Va
    Posts
    11
    Why dont you just clean them with break cleaner and see what that does for you.

  8. #8
    Registered User wagonmaster's Avatar
    Join Date
    Aug 2009
    Location
    Tucson, AZ
    Posts
    469
    I think he's got a little more going on that just some brake dust....

  9. #9
    Banned
    Join Date
    Nov 2002
    Location
    Lyndon, Kansas
    Posts
    7,511
    check to see if your pads are getting worn enough to where new contact area is hitting a rusty part of the rotor. if you have rear discs then it may be the park brakes squeaking.

    could be the pad. some pads just squeak.


    89' S10 blazer 4wd: 355, 650 dp, rpm intake, comp 282 roller cam, modified vortecs, T56 Six speed, 8.8 ls rear, headers, x-pipe, spintech pro street mufflers, and......AC

    Blazer burnout video - http://www.youtube.com/watch?v=sP7iLypoDI4

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •