Results 1 to 11 of 11

Thread: Pressure build up in fuel tank. Is this normal?

  1. #1
    1st Gen. blazer yawdie1's Avatar
    Join Date
    Mar 2009
    Location
    Minnesota
    Posts
    69

    Pressure build up in fuel tank. Is this normal?

    So has anyone run into this? After driving my blazer with an LT1. I would hear air pressure coming out from my fuel tank. I don't smell gas. There is a new corvette fuel pump in the new tank. There is also a new fuel cap. Is this normal?
    91 s10 blazer, with a 93 LT1, 5/4 drop on 20" Boss 338 rims.

  2. #2
    Registered User wagonmaster's Avatar
    Join Date
    Aug 2009
    Location
    Tucson, AZ
    Posts
    469
    Do you have emissions on that engine?

    You might want to try the old gas cap and see if it does it still.

  3. #3
    Orlando AD Pres. ON-D-FLOOR's Avatar
    Join Date
    Oct 2004
    Location
    orlando, deltona, FLORIDA
    Posts
    99
    also is your tank vent line open? if you blocked it off and are running a non-vented gas cap, that would cause that problem...you can easily fix it by taking a drill and drilling a 1/8 in hole in the cap.. that will allow the pressure to vent..
    ON D FLOOR- the best way to be!!!:cool:

  4. #4
    5.7L VORTEC 350 blazin4low's Avatar
    Join Date
    Aug 2002
    Location
    Jax,FL
    Posts
    2,613
    make sure you didn't smash any lines between the tank straps when you put the tank back in after changing the pump


    I say this because I did it and had to drop the tank again
    http://i158.photobucket.com/albums/t114/VortecBlazer/sidredo.jpg
    Tuned by Bland Tuning
    Transmission built by Transbuilderguy on FSC!
    Marine Intake swap by me

  5. #5
    1st Gen. blazer yawdie1's Avatar
    Join Date
    Mar 2009
    Location
    Minnesota
    Posts
    69
    Quote Originally Posted by wagonmaster View Post
    Do you have emissions on that engine?

    You might want to try the old gas cap and see if it does it still.
    I think it did the same thing with the old one. I will check again...... no I think I threw it away.
    91 s10 blazer, with a 93 LT1, 5/4 drop on 20" Boss 338 rims.

  6. #6
    1st Gen. blazer yawdie1's Avatar
    Join Date
    Mar 2009
    Location
    Minnesota
    Posts
    69
    Quote Originally Posted by ON-D-FLOOR View Post
    also is your tank vent line open? if you blocked it off and are running a non-vented gas cap, that would cause that problem...you can easily fix it by taking a drill and drilling a 1/8 in hole in the cap.. that will allow the pressure to vent..
    I'm pretty sure that I bought a vented cap. Or is it a pressure cap? I did replace the vent hose. I don"t think it's kinked or anything. The only thing I remember blocking off is the port that goes to the fumes canister.
    91 s10 blazer, with a 93 LT1, 5/4 drop on 20" Boss 338 rims.

  7. #7
    1st Gen. blazer yawdie1's Avatar
    Join Date
    Mar 2009
    Location
    Minnesota
    Posts
    69
    Quote Originally Posted by blazin4low View Post
    make sure you didn't smash any lines between the tank straps when you put the tank back in after changing the pump


    I say this because I did it and had to drop the tank again
    So when you had the smashed line, did it drive ok? how was your fuel pressure?
    91 s10 blazer, with a 93 LT1, 5/4 drop on 20" Boss 338 rims.

  8. #8
    5.7L VORTEC 350 blazin4low's Avatar
    Join Date
    Aug 2002
    Location
    Jax,FL
    Posts
    2,613
    Didn't notice anything until I went to fill up with gas and the pressure vented as I unscrewed the cap
    http://i158.photobucket.com/albums/t114/VortecBlazer/sidredo.jpg
    Tuned by Bland Tuning
    Transmission built by Transbuilderguy on FSC!
    Marine Intake swap by me

  9. #9
    1st Gen. blazer yawdie1's Avatar
    Join Date
    Mar 2009
    Location
    Minnesota
    Posts
    69
    Quote Originally Posted by blazin4low View Post
    Didn't notice anything until I went to fill up with gas and the pressure vented as I unscrewed the cap
    I will check the fuel lines again. I put in all new aluminum and braided steel fuel lines. So I'm pretty sure that there are no kinks.
    91 s10 blazer, with a 93 LT1, 5/4 drop on 20" Boss 338 rims.

  10. #10
    1st Gen. blazer yawdie1's Avatar
    Join Date
    Mar 2009
    Location
    Minnesota
    Posts
    69

    vent cap

    So I did some searching and made some phone calls. It turns out that I blocked off my vent from the tank. I was thinking that my vented gas cap was enough but I was wrong. 2 ways to fix this. one I drop the tank and put a filtered vent on it. two, I drill a bigger hole in the gas cap. I went with #2. I will drop the tank in the winter. The bigger hole in the cap seems to help alot. So thank you all for your:D help!
    91 s10 blazer, with a 93 LT1, 5/4 drop on 20" Boss 338 rims.

  11. #11
    Registered User wagonmaster's Avatar
    Join Date
    Aug 2009
    Location
    Tucson, AZ
    Posts
    469
    Cool, got it fixed!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •