Results 1 to 5 of 5

Thread: HELP: Bought blazer need help with issues

  1. #1
    Registered User
    Join Date
    Feb 2011
    Posts
    2

    HELP: Bought blazer need help with issues

    Ok first off new to this forum and also new to Blazer's. I picked up a 1995 4 door blazer 4x4 4.3 Vortech with over 200,000 on the clock for a nice winter vehicle. Everything worked good when I got her and now Im running into some problems. Please assist in anyway. Thank you Also for your viewing pleasure a few pics :cool:

    1. It now seems to be riding a little rough, meaning that the idle of the vehicle seems to be very low almost to the point of stalling out when sitting at a red light. I'm assuming plugs and/or wires

    2. The heater just stopped working. When I first got her the heat did work but didn't blow out the vents. Just up by the defrosters and down by the feet. So not sure why its not blowing out the vents and now now hot air at all. Checked and replaced thermostat and refilled radiator. On top of that when I make a turn I can hear fluid sloshing around by the heater core. Is that normal? No leaks that I can see. When I drive it and have the heat full blast it takes for ever for the car to warm up and if I leave the heat on too long the temperature will rise above normal and won't go down until the heat is off.

    3. Hood latch cable is broke. Now the previous owner tied a wire to the latch so I can open the hood, however would like to replace the cable. Has anyone tackled this project, is there a write up somewhere, or any info would be appreciated on this. Also when the hood pops up its hard as hell to open I pull up on the lever and have to shimmy the hell out of it, now I figure the latch is just bent, I saw this on ebay will this work? http://cgi.ebay.com/ebaymotors/ws/eB...=STRK:MEWAX:IT He said came off a 2000.

    4. No lights around the heater controls. Wasn't sure if this is a simple fix as far as a bulb and if so what kind? Or some other problem.


  2. #2
    Registered User dragnblazer's Avatar
    Join Date
    Mar 2004
    Location
    Las Vegas, Nv
    Posts
    2,102
    2.try flushin the heater core that might help. my heat wasnt blowing for crap. i did the normal system flush and thermo stat change after i bought mine thinking it was stuck or clooged. didnt help. i desided to flush just the heater core and got some results. beware flushing the core can cause it to fail. i.e coolant in the cab. so get yourself a fiting or somthing to union the 2 heater core hoses together to keep ya on the round if that happens.

    now having said that i would first drive your truck with no heat on or anything. pull over park you can shut off the motor or leave it on dosent matter. check the 2 heater core hoses on the fire wall passenger side. they both should be warm or hot. if one is cooler than the other your core needs to be relaced. you can flush it like you would the radiator. but replacing it in my opinion is the only way to fix it and not worry about it failing. until that new one fails..lol. anyways what i did was removed the 2 hoses from the motorside not the fire wall. ran one the hose that was on the water pump/heater core down towards the a arm and connected the garden hose to the other hose maifold/heater core with a fitting and 2 hoses clamps let it run till it ran clear. and then did the same on the otherside. but that time i ran to hose over the distributor past the break booster and over the driverside fender.

    this sound give you some warm/hot air depending on how bad the core may or maynot be clogged. as for the air not comoing out the vent it could be the fan but i dont know anything about that so sorry. as for hearing water slooshing as you put it i heard the same sorta thing with mine flushed the system and had the noise reduced but came back. after the core flush it went away. sounds to me like someone put in stop leak in it. where the leak was who knows stop leak is the one of the worse thing ever made that is sold at repair stores and isle. you said it takes awhile to warm up the car with the heat on. i assume you are starting the truck and turning the heat on. the heater core uses hot water off the cooling system delivered via the heater core hoses off th water pump. make sure you dont have a bubble in your system. also make sure none of the hoses are rock hard if so replace them asap.


    3.

    the hood latch cable is very simple to replace. as far as a write up i never seen one. i did it on my 89 in 30 mins so its pretty straight foward ijust removed to old and replaced it with the new starting under the hood and then feed the new one thru the dash then screwd it in.


    as far as the latch goes i have no idea

    hope it helps
    Last edited by dragnblazer; 02-19-2011 at 04:51 PM.
    My project thread 89 bagged 2door
    http://www.blazinlow.com/forum/showthread.php?t=68023

    Wife's daily
    2002 chevy blazer 4 door 2wd ls

    My daily
    2000 Gmc jimmy 2 door 5 speed

  3. #3
    Registered User dragnblazer's Avatar
    Join Date
    Mar 2004
    Location
    Las Vegas, Nv
    Posts
    2,102
    btw get a new plate enless your really dons lady!
    My project thread 89 bagged 2door
    http://www.blazinlow.com/forum/showthread.php?t=68023

    Wife's daily
    2002 chevy blazer 4 door 2wd ls

    My daily
    2000 Gmc jimmy 2 door 5 speed

  4. #4
    Registered User
    Join Date
    Feb 2011
    Posts
    2
    Quote Originally Posted by dragnblazer View Post
    btw get a new plate enless your really dons lady!

    lmfao...ummm no, that was the plates of the lady who I bought it off of. Like the idea about the heater core you suggested. I kinda figured that was going to have to be done, I just didn't understand why it didn't blow through the vents. I'm thinking maybe a vacuum line so I'm going to check all those also.

  5. #5
    Registered User dragnblazer's Avatar
    Join Date
    Mar 2004
    Location
    Las Vegas, Nv
    Posts
    2,102
    check the fan also. you could allways replace the core. your gonna hate that repair. i had to do it on my 89 the day i got it home i opend the passenger door for my buddy to show him how nice the interior was and green coolant came running out the floor boards onto the ground. i was like WTF! we had to remove the dash to get to the core. you could allways bypass the core but you will lose defrost and heat. and being in ohio fuck that! i live in las vegas and i hate not having heat im gonna change my core this summer.
    My project thread 89 bagged 2door
    http://www.blazinlow.com/forum/showthread.php?t=68023

    Wife's daily
    2002 chevy blazer 4 door 2wd ls

    My daily
    2000 Gmc jimmy 2 door 5 speed

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •