Results 1 to 7 of 7

Thread: Blazer won't start

  1. #1
    Reverse Engineer tester239's Avatar
    Join Date
    Sep 2004
    Location
    Washington
    Posts
    592

    Blazer won't start

    I've got a 1991 S10 blazer 4.3l v6 (tbi) that will turn over, has spark and fuel going to the engine.. but won't run on it's own. Replaced plugs, wires, coil, ignition module, ignition pickup coil in distributor, cap, rotor. Wires are in the correct order on the cap. It will sound like it wants to run, but never gets going. I've been able to move the distributor around and get it to do nothing, then move it some more, backfire, move it some more, and then occasionally fire on it's own.. but never get going. ECM only reads code 12.

    I had originally just wanted to replace the cap and rotor, but after taking those parts off, I noticed the wire to the coil was bad and had been arcing. So I replaced all the wires, the coil, cap, rotor, and plugs as well. I was able to start it up, and then moved it from the work area to the street where it's normally parked. I come back out a few days later and it won't start. I ended up checking the pickup coil, and it was open. Replaced that, still didn't work. Replaced the ignition module, still nothing new.. Keep in mind, replacing the pickup coil requires disassembling the distributor. I marked the drive gear in relation to the rotor so it SHOULD be back together properly..

    What else can I check? Do I have the distributor put in incorrectly (rotor pointing the wrong direction)? Ideas? Thanks for any help guys!
    CAPS LOCK IS CRUISE CONTROL FOR AWESOME
    Stock 0wns.
    4 Door Love
    Digital Love

  2. #2
    5.7L VORTEC 350 blazin4low's Avatar
    Join Date
    Aug 2002
    Location
    Jax,FL
    Posts
    2,598
    sounds like your 180 out........you need to get to TDC, and reset your distributor
    http://i158.photobucket.com/albums/t114/VortecBlazer/sidredo.jpg
    Tuned by EFI Alchemy
    Transmission built by Transbuilderguy on FSC!

  3. #3
    Reverse Engineer tester239's Avatar
    Join Date
    Sep 2004
    Location
    Washington
    Posts
    592
    Quote Originally Posted by blazin4low View Post
    sounds like your 180 out........you need to get to TDC, and reset your distributor

    Yeah, I thought that too. Tried lining it up, when at TDC.. then proceeded to try every possible way I could insert the gear.. I'm starting to think the timing chain skipped or is bad... :mad: :bang:
    CAPS LOCK IS CRUISE CONTROL FOR AWESOME
    Stock 0wns.
    4 Door Love
    Digital Love

  4. #4
    Registered User dragnblazer's Avatar
    Join Date
    Mar 2004
    Location
    Las Vegas, Nv
    Posts
    2,057
    Maybe its a tooth off.
    Bagged on 18's over the axle, foward 4 link, 8 1/2 valves, 2 viair 480s, EAI 7 switch box, 8 gallon tank, flowmaster 40, shaved gas door, doors handles, key holes and roof rack/roof ribs. chrome front bummper with out strip holes, clear bummper lights and corner lights. 1st gen s10 bench seat. painted to match ss mirrors.

    My project thread
    http://www.blazinlow.com/forum/showthread.php?t=68023

    =SUNSET= Las Vegas, NV

    The Daily
    2002 chevy blazer 4 door 2wd ls

  5. #5
    Reverse Engineer tester239's Avatar
    Join Date
    Sep 2004
    Location
    Washington
    Posts
    592
    So, erm... Timing chain checking/replacement. I have 4-wheel drive. The service manual makes the task sound very daunting. Do I actually need to remove the oil pan to remove the front cover, or can I skip this step?
    CAPS LOCK IS CRUISE CONTROL FOR AWESOME
    Stock 0wns.
    4 Door Love
    Digital Love

  6. #6
    streetissuecustoms.com low_blazer's Avatar
    Join Date
    Dec 2001
    Location
    Poulsbo, Washington
    Posts
    1,967
    You may not need to fully drop the pan, but definately need to losen the pan and drop the front of it, the timing cover mounts in between the pan and block.

    I would seriously recheck your distributor install...if it's popping through the tb, then it's still 180 out. Just because you have it lined up at what you think it TDC, doesn't mean it is. If you've got it 180 out, it will be firing on the intake stroke instead of the compression stroke, and will push the fire through the intake.

    If you're just backfiring, then you've probably got some plug wires out of order...re-check firing order and retrace the wires....
    Doug
    '85 Blazer...bagged, small-blocked, back-halfed and body dropped
    http://streetissuecustoms.com/salesban_3.jpg
    Street Issue Customs

    For all your custom fiberglass, interior or stereo needs... Epicenter Designs

    Originally posted by S/T Lover
    That post would have made more sense if you would have just pissed all over the screen and posted a screen shot of that.

  7. #7
    Reverse Engineer tester239's Avatar
    Join Date
    Sep 2004
    Location
    Washington
    Posts
    592
    Checked and rechecked the wires (had somebody else do it too). Tried the dist every way I could possibly do. Just wouldn't go. I was already prepping it to be sold, so I tried to sell it as is. Nobody even nibbled so I sold it to the wrecking yard. Good bye, my first vehicle! *sniff*
    CAPS LOCK IS CRUISE CONTROL FOR AWESOME
    Stock 0wns.
    4 Door Love
    Digital Love

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •