Results 1 to 10 of 10

Thread: starting up issues

  1. #1
    Registered User alterednitemare's Avatar
    Join Date
    Jan 2012
    Location
    gilbert arizona
    Posts
    35

    starting up issues

    i just bought a 97 blazer with the 4.3 engine about a month ago and it has been sitting since september. in the morning and after about 7 hours of sitting i try to start the truck and it cranks but wont turn over till i spray a little starting fluid in it. any comments or suggestions will be greatly appreciated.

  2. #2
    5.7L VORTEC 350 blazin4low's Avatar
    Join Date
    Aug 2002
    Location
    Jax,FL
    Posts
    2,613
    Fuel pressure regulator?
    http://i158.photobucket.com/albums/t114/VortecBlazer/sidredo.jpg
    Tuned by Bland Tuning
    Transmission built by Transbuilderguy on FSC!
    Marine Intake swap by me

  3. #3
    Registered User alterednitemare's Avatar
    Join Date
    Jan 2012
    Location
    gilbert arizona
    Posts
    35
    i'll definitely check that. thanks for the info

  4. #4
    Registered User suncad03's Avatar
    Join Date
    Sep 2005
    Location
    mooresville, NC
    Posts
    259
    i had the same problem on my 99. it was the fuel pump, i am unsure put i think the 97 is the same engine. the newer vortech engine the fuel pump controls the fuel pressure. there is not a bolt on pressure regulator. i think 58psi is min to start but will stay running off less pressure. mine was at 42psi and if i put just a little gas in the throttle body it would start and run till i turned if off. the fuel pumps on these trucks are vary common to go bad.

  5. #5
    5.7L VORTEC 350 blazin4low's Avatar
    Join Date
    Aug 2002
    Location
    Jax,FL
    Posts
    2,613
    check your fuel pressure and report back and while checking the pressure if it leaks down to 0psi in matter of seconds you have a bad regulator. you can change the regulators on the spider injectors but you do have to take the upper intake off to do so.

    if your pressure doesn't reach 52psi or higher, pinch the return line and see what the max psi the pump is putting out. if your still only getting the psi you were getting without the return line pinched your pump is bad. if you get around 80psi with the return line pinched your regulator is good.

    also if you take the upper intake off and the cast lower intake is very clean under the regulator, the regulator is leaking and needs to be replaced.

    but check your pressure and report back
    http://i158.photobucket.com/albums/t114/VortecBlazer/sidredo.jpg
    Tuned by Bland Tuning
    Transmission built by Transbuilderguy on FSC!
    Marine Intake swap by me

  6. #6
    Zombie Killer 6SpeedBlazer's Avatar
    Join Date
    May 2004
    Location
    Lake St. Louis
    Posts
    6,594
    Quote Originally Posted by suncad03 View Post
    i had the same problem on my 99. it was the fuel pump, i am unsure put i think the 97 is the same engine. the newer vortech engine the fuel pump controls the fuel pressure. there is not a bolt on pressure regulator. i think 58psi is min to start but will stay running off less pressure. mine was at 42psi and if i put just a little gas in the throttle body it would start and run till i turned if off. the fuel pumps on these trucks are vary common to go bad.
    this is false. even the new vortec engines (aka 5.3 and all other LSx based engines) has a fuel pressure regulator, its just built into the fuel filter.

  7. #7
    Registered User alterednitemare's Avatar
    Join Date
    Jan 2012
    Location
    gilbert arizona
    Posts
    35
    i checked the bleeder valve by the intake and it has pressure. but i think its the fuel pump cause my dad was saying the gas is all going whacko and not wanting to start alot more now

  8. #8
    5.7L VORTEC 350 blazin4low's Avatar
    Join Date
    Aug 2002
    Location
    Jax,FL
    Posts
    2,613
    how much pressure?

    just because it sprays fuel out when you press the nipple in doesn't mean it has enough pressure
    http://i158.photobucket.com/albums/t114/VortecBlazer/sidredo.jpg
    Tuned by Bland Tuning
    Transmission built by Transbuilderguy on FSC!
    Marine Intake swap by me

  9. #9
    Registered User alterednitemare's Avatar
    Join Date
    Jan 2012
    Location
    gilbert arizona
    Posts
    35
    i finally replaced me fuel pump after looking for it awhile and found it for 51 bucks shipped and now it starts everytime right away

  10. #10
    5.7L VORTEC 350 blazin4low's Avatar
    Join Date
    Aug 2002
    Location
    Jax,FL
    Posts
    2,613
    good deal
    http://i158.photobucket.com/albums/t114/VortecBlazer/sidredo.jpg
    Tuned by Bland Tuning
    Transmission built by Transbuilderguy on FSC!
    Marine Intake swap by me

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •