Results 1 to 8 of 8

Thread: ABS Code C0237

Hybrid View

Previous Post Previous Post   Next Post Next Post
  1. #1
    IlluSive XpecTaionS l1ld3v1lrydr's Avatar
    Join Date
    Jan 2005
    Location
    middleburg, pa
    Posts
    1,489

    ABS Code C0237

    2003 s10 blazer, 4wd. ABS light comes on and the ABS sometimes kicks on while I'm braking. E Brake light flashes a few times on dash and speedometer jumps around. Had my shop guy hook his computer up to it and it gave us that code and he said its the "Rear Wheel Speed Sensor". Now I just bought the blazer, and the dealer said the light was on when he got it, but he replaced the ABS module under the hood and the light was off... Up until the day after I brought it home.


    Question is.. Where is the damn thing. lol. And is it easy to replace?
    :tongue: w1shf00l th1nk1n' :boink:

    4 door love... or... love-in the 4 door... :bigthumb:



  2. #2
    I'm BATMAN! Harley's Avatar
    Join Date
    Jun 2003
    Location
    Warren, MI
    Posts
    2,420
    The ABS system in an S truck uses the Vehicle Speed Sensor (VSS) in the transmission to measure the rear wheel speed. If you're speedo and everything else is working fine then the VSS is working. With that in mind there must be a break or short in the circuit between the Powertrain Control Module and the ABS module.

    To test the VSS circuit start at the ABS module. The main connector has 16 cavities. Unplug it with the vehicle off and then turn the ignition to on. Pin B1 is the VSS circuit and should be a green wire with a white stripe. Using a Digital Multimeter measure from pin B1 to a good ground. Value should be greater than 10V. If it is than support the vehicle in the air and measure the same circuit while having someone spin the rear wheels by hand to get the driveshaft roatating. This measurement should be between 5-7 volts.

    If either of those tests fail check for a broken or short circuit. Corrosion at the ABS module, connector C101, or the PCM is a likely candidate. The schematic below should help you hunt it down. Just keep measuring the same test that failed at each connector until a correct measurement is found.

    C101 is a 10 cavity connector and is located near the PCM.


    Speed Sensor Signals by TheHarley, on Flickr
    Black 'n Tanazer, Long Bed, Coupe Quattro, Old Caddy, Old Rice

    Member of the SCUDS Task Force
    Spike Clean Up & Disposal Service

  3. #3
    IlluSive XpecTaionS l1ld3v1lrydr's Avatar
    Join Date
    Jan 2005
    Location
    middleburg, pa
    Posts
    1,489
    The speedo isn't fine though, it jumps around. And this morning the ABS kicked on the whole way down my drive way while the brake light flashed and speedo bounced around.
    :tongue: w1shf00l th1nk1n' :boink:

    4 door love... or... love-in the 4 door... :bigthumb:



  4. #4
    I'm BATMAN! Harley's Avatar
    Join Date
    Jun 2003
    Location
    Warren, MI
    Posts
    2,420
    Sounds like a short in the main VSS circuit or the sensor itself is going bad. Probably easiest to replace the sensor and see if that fixes it.

    Driver side of the transfer case. #1 is the VSS.


    VSS Location 4WD by TheHarley, on Flickr
    Black 'n Tanazer, Long Bed, Coupe Quattro, Old Caddy, Old Rice

    Member of the SCUDS Task Force
    Spike Clean Up & Disposal Service

  5. #5
    IlluSive XpecTaionS l1ld3v1lrydr's Avatar
    Join Date
    Jan 2005
    Location
    middleburg, pa
    Posts
    1,489
    That's what I think I'm gunna try first. Will any fluid come out with that?
    :tongue: w1shf00l th1nk1n' :boink:

    4 door love... or... love-in the 4 door... :bigthumb:



  6. #6
    I'm BATMAN! Harley's Avatar
    Join Date
    Jun 2003
    Location
    Warren, MI
    Posts
    2,420
    I doubt much if any. If you're paranoid about it just elevate the rear of the truck more than the front when you pull it out.
    Black 'n Tanazer, Long Bed, Coupe Quattro, Old Caddy, Old Rice

    Member of the SCUDS Task Force
    Spike Clean Up & Disposal Service

  7. #7
    IlluSive XpecTaionS l1ld3v1lrydr's Avatar
    Join Date
    Jan 2005
    Location
    middleburg, pa
    Posts
    1,489
    Not paranoid. Just want to be prepared when I go to change it. I really hope that's the problem. It seems to be getting worse. hopefully this weekend I will tackle it.
    :tongue: w1shf00l th1nk1n' :boink:

    4 door love... or... love-in the 4 door... :bigthumb:



  8. #8
    Registered User fuzzyheadtim's Avatar
    Join Date
    Nov 2012
    Location
    patterson,louisiana
    Posts
    19
    mine was doing alot of the same thing.....speedometer jumping around the abs light comes on sometimes but the speedometer dosent work now......and neither does the cruse control...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •