Results 1 to 5 of 5

Thread: Need help. 4.3 tbi has me stumped

  1. #1
    Registered User Sm0k3's Avatar
    Join Date
    Nov 2013
    Location
    Salem Al
    Posts
    2

    Need help. 4.3 tbi has me stumped

    I have a 90 blazer, i drove it to the store couple months ago and it would not start. only signs of a problem prior were it would turn over 4-8 times before it would crank. i have replaced spark plugs (and there getting spark), wires. distributor cap, button and the ignition module attached to it. i rebuilt the throttle body and fuel pres regulator and changed the fuel filter. haven't been able to get it to even try to start even tho its getting air fuel and spark. The rotor button is turning and points to where it should at top dead center so timing chain isnt broken. it has me stumped... any help would be greatly appreciated. I am new to the site but looks great, thanks in advance. my email is dead_ent_sm0k3@yahoo.com

  2. #2
    Registered User Sm0k3's Avatar
    Join Date
    Nov 2013
    Location
    Salem Al
    Posts
    2
    if anymore info is needed or anybody has any ideas please let me know. tried searching the site to no avail. so links or anything would be helpful and greatly appreciated. this truck is to nice to b collecting leaves in my driveway lol.

  3. #3
    lowered member mpeace's Avatar
    Join Date
    Jun 2004
    Location
    Rome, GA
    Posts
    1,155
    Computer maybe or a loose connection at the computer.
    Just a thought
    If you can't do your custom work yourself then sell your ride.

  4. #4
    5.7L VORTEC 350 blazin4low's Avatar
    Join Date
    Aug 2002
    Location
    Jax,FL
    Posts
    2,615
    What's your fuel pressure at? Sounds like your pump is gone.
    http://i158.photobucket.com/albums/t114/VortecBlazer/sidredo.jpg
    Tuned by Bland Tuning
    Transmission built by Transbuilderguy on FSC!
    Marine Intake swap by me

  5. #5
    Member 14 Rapid Ron's Avatar
    Join Date
    Oct 2001
    Location
    Overland Park, KS
    Posts
    723
    When you turn the key (on position) do you hear the fuel pump run for a couple of seconds?
    If you don't, check for voltage to fuel pump relay (located on drivers fender) if relay is good it's the fuel pump.
    A bad fuel pump may work for awhile then not work.
    '88, half bagged, 4.3, auto, 241k, 18" IROCS, blah, blah, blah

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •