Results 1 to 4 of 4

Thread: Cylinder Heads

  1. #1
    Moderator 8mpg's Avatar
    Join Date
    Oct 2001
    Location
    Sequim Washington
    Posts
    1,877

    Cylinder Heads

    I have been looking at some Trick Flow 23 Degree Heads. They are pretty nice. I am not exactly sure which ones to get. I also looked at some AFR 190's. Those look like they put out a little more power. Anyone really done any serious reasearch? Blazin Low You have those Dart Iron Eagle Heads? Are those pretty nice?

    My dad found out that I ordered that blower and put a stop to that.

    He told me that that was a redicilous price and he could find me a better deal on a blower If I really want one. "He doesnt like them"



    Oh another thing. My 383 makes a kind of a pinging/clacking noise when I just step on it. I parked it until I completely figure out whats wrong with it. It starts to ping around 4 thousand rpm or so. I know it might be my cam hitting my rods, but wouldn't it hit them even at idle? Or below 4 thousand rpms?
    Hold my hammer while I nail your girlfriend

  2. #2
    Administrator Blazin Low's Avatar
    Join Date
    Oct 2001
    Location
    In Front of You
    Posts
    4,702
    The Dart Iron Eagle heads are pretty good, they brought me from a 14.1 to a 13.2 in the 1/4 mile, a mild cam upgrade too.

    I had problems with the valve guides wearing out 2 different occasions. 1st time they wore out so bad one of the valves got stuck open, the piston hit it, broke it off, and destroyed my motor.

    Heres the damage:
    http://www.blazinlow.com/video/engineblow.asf

    I think it was my fault, wasnt tuned right, timing too low, running too rich, generated too much heat in the valve and just wore them down.

    Since then Ive been more careful about that. As far as I know, theyre OK...
    this is a test of the sig

  3. #3
    Registered User
    Join Date
    Oct 2001
    Location
    Avon,Ct
    Posts
    7
    do you have a 700r4? cause my truck made that same wierd noise and only at 4 grand i have no clue what exactly it was but i guess it was the tranny cause i had it repaired.

  4. #4
    Slow Ride
    Guest
    .
    Last edited by Slow Ride; 04-25-2002 at 02:47 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •